-1

I have a raspberry pi 3b+ which I want to connect to two seperate networks.

I have an existing ethernet connection which works fine, and i am able to SSH/VNC to the pi over this network.

I have cobbled together a configuration from other questions on here, to attempt to get the WiFi up. My configuration is as follows:

WPA_SUPPLICANT.CONF

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


network={
    ssid = "MYSSID"
    scan_ssid = 1
    psk="MYPASS"
    id_str="WIFI ACCESS"
    #prioirty=5
}

/etc/netowrk/interfaces

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet static
address w.x.y.z
netmask 255.255.240.0

auto wlan0
allow-hotplug eth0
iface wlan0 inet static
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
address a.b.c.d
netmask 255.255.240.0
broadcast a.b.c.254
gateway a.b.c.254

iface default inet dhcp

I created a file in /etc/default named ifplugd

/etc/default/ifplugd

INTERFACES="eth0"
HOTPLUG_INTERFACES="eth0"
ARGS="-q -f -u0 -d10 -w -I"
SUSPEND_ACTION="stop"

Edited my rc.local file to ensure wlan starts up

/etc/rc.local

# Print the IP address
_IP=$(hostname -I) || true
if [ "$_IP" ]; then
  printf "My IP address is %s\n" "$_IP"
fi

#disable the ifplugd eth0
sudo ifplugd eth0 --kill
sudo ifplugd wlan0

exit 0

I rebooted my pi and no WLAN was found. I don't know if there's some config i've missed/gotten wrong, or if it's an incorrect p/w for the SSID.

5
  • 1
    You have NOT set WiFi country, have not specified OS (I presume Raspbian Stretch) and appear to be using obsolete settings in /etc/netowrk/interfaces (sic). I suggest you do a fresh install of Raspbian THEN explain WHAT you are trying to achieve. – Milliways Sep 24 '18 at 11:09
  • See How to set up networking/WiFi – Milliways Sep 24 '18 at 11:15
  • "I don't know if there's some config i've missed/gotten wrong, or if it's an incorrect p/w for the SSID." -> If you try running wpa supplicant in the foreground yourself, it should provide details (they might already be in the system log): sudo wpa_supplicant -i wlan0 -c [/path/to/your/config] -d. – goldilocks Sep 24 '18 at 15:13
  • One thing is definitely wrong: you cannot use broadcast address a.b.c.254 as gateway. – Ingo Sep 26 '18 at 21:49
  • Hi @Thom G, you don't reply. Have you followed the suggestions? Does it work now? Are you still interested in help? – Ingo Oct 17 '18 at 8:11
0

If you are trying to connect to an existing wifi network on Raspbian os then you can use raspi-config quick setup

https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

Or if you want to setup your own wifi hotspot network with hostpad and dnsmasq then you can follow this

https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

0

I suggest you use NetworkManager to perform the setup.

Steps:

  1. sudo apt update

  2. sudo apt full-upgrade

  3. sudo apt dist-upgrade

  4. sudo apt install network-manager network-manager-gnome

  5. sudo systemctl stop dhcpcd

  6. sudo systemctl disable dhcpcd

  7. sudo systemctl enable NetworkManager

  8. sudo systemctl start NetworkManager

  9. sudo reboot now

  10. Now connect to a wifi network using the new network manager you will find the the icon NetworkManager Icon on the task bar.

  11. Select each connection and press the settings icon.Select connection press settings in yellow

  12. Edit the settings menu to configure to your needs. The image is from selecting the mode pull-down list.Configure WiFi connection Mode

I've done this on a Pi Zero W with an external USB-Ethernet port to share the WiFi connection with a Ethernet only device. I've also tried this on a Pi 4 so it should work for you.

The information is based on the site: https://dennymichael.net/2019/10/22/share-wifi-internet-with-ethernet-port-on-raspberry-pi-bridge/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.