Whenever I download Raspbian Jessie 8 and install it, it automatically works with 7inch display and a full up monitor through ribbon cable and HDMI cable respectively. However, when I plug in the 3.5PiTFT or 2.8PiTFT display to the GPIO pins, I get nothing on the screen. I suppose I need to do something to the configuration file, but I am not sure what I need to change or add. Any help will be greatly appreciated. Thanks.

  • 1
    It's going to depend on the manufacturer and the specific model. You should have received instructions, a link, or a prebuilt SD image with the LCD. HDMI is an autonegotiating protocol and delivery mechanism for video. GPIO is general purpose (the GP part), so you usually need to do more things to get them working. The good news is that it's easier than ever to get that sort of thing up and running. – YetAnotherRandomUser Sep 27 '18 at 16:29
  • @YetAnotherRandomUser I have always used the prebuilt images for running raspbian with 2.8 or 3.5 pitft display and they have always worked but ONLY ON PI 2. Every part of the PI was able to be used, but I NO longer have PI 2. I only have pi 3 for use. So, I installed these prebuilt images on PI 3. The display still works as expected, but now PI 3 won't let me use the serial GPIO PINS. I've tried pretty much everything and asked question here. I still can't get my software to communicate through serial pins. So,I installed full up jessie 8 to get the pitft display to work with no success. – ThN Sep 27 '18 at 20:48
  • this comment follows the above comment... but I found a script adafruit-pitft.sh script that is suppose to automatically help you with this problem. I ran it and it seems to work but I still can't get my pitft to work. – ThN Sep 27 '18 at 20:49
  • I found a script adafruit-pitft.sh script that is suppose to automatically help you with this problem It will work for the adafruit screens, but not necessarily for any random screen. – Dirk Sep 28 '18 at 6:12
  • @Dirk I am using Adafruit dipslay and I found that script on adafruit website. The issue is that when I use prebuilt image for the adafruit display, I loose access to serial GPIO pins on PI3, but the display works as expected. If I install the full up or base jessie 8 on pi3 and then try to get the adafruit pitft working. the display won't work. I even tried the script I mentioned about and still no luck. – ThN Sep 28 '18 at 13:58

Based on your comments, it seems that there are specific GPIO pins that aren't working.

This answer and it's answers seems to address the issue, namely that one of the serial ports is being used by the Bluetooth of the Pi 3 (also applies to Pi 0)

The BCM2837 on the Raspberry Pi3 , Pi3B+, PiZeroW has 2 UARTs (as did its predecessors), however to support the Bluetooth functionality the fully featured PL011 UART was moved from the header pins to the Bluetooth chip and the mini UART made available on header pins 8 & 10.

You'll probably need to make some configurations to enable and configure the serial port, again per the answer above.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.