1

If I try to install something using pip it gives me a weird error. Time is set correctly and sudo doesn't change anything. For example I try installing conan pip install conan​ gives an error:

pi@raspberrypi:~ $ pip install conan
​Invalid requirement: 'conan​'
Traceback (most recent call last):
  File "/home/pi/.local/lib/python2.7/site- 
packages/pip/_internal/req/req_install.py", line 253, in from_line
  req = Requirement(req)
File "/home/pi/.local/lib/python2.7/site- 
packages/pip/_vendor/packaging/requirements.py", line 97, in __init__
requirement_string[e.loc:e.loc + 8]))
InvalidRequirement: Invalid requirement, parse error at "'\xe2\x80\x8b'"

What could be the possible solution for this?

2

I just got the same error today, it can be resolved by typing in:

sudo pip install --no-cache-dir conan

If you run it with the -v (verbose) you can see it errors at some point in the cache.

  • If possible, please talk a little bit about why this would resolve the problem stated in the question – Mohammad Ali Sep 30 '18 at 1:31
  • I would if I knew more about why it worked. All I know is I saw cache errors in verbose mode and by running it without using the cache dir it worked. – Electro Intellect Oct 13 '18 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.