0

After downloading the newest image from the official Raspberry Pi website, I formatted the SD-card (8gb) and I put the new image on the SD with Etcher. After reinstalling the image I had no WiFi anymore, the RPI couldn't even find a wireless interface. Now, I can only connect to my RPI with an ethernet cable.

I have already tried numerous things. I have tried:

  • updating/upgrading the OS.
  • configuring the network settings via /etc/wpa_supplicant/wpa_supplicant.conf
  • adding an external WiFi adapter from the company Edimax.
  • editing the interface configurations via /etc/network/intefaces
  • rebooting.
  • reinstalling the OS again.

side note: Etcher gave me a weird Error after formatting my SD. Something about SSH and permissions.

Some pictures of my current situation: enter image description here enter image description here enter image description here enter image description here enter image description here

enter image description here

10
  • 1
    Post TEXT not images The files you listed are NOT those in a fresh install
    – Milliways
    Oct 2, 2018 at 21:59
  • Well, I changed it a bit. Because it wasnt working after fresh install
    – Stefan
    Oct 2, 2018 at 22:07
  • side note: Etcher gave me a weird Error after formatting my SD. Something about SSH and permissions.
    – Stefan
    Oct 2, 2018 at 22:13
  • Etcher doesn't do SSH Oct 2, 2018 at 23:07
  • 1
    to see what they look like, don't touch them after flashing :p Oct 3, 2018 at 0:08

2 Answers 2

1

After flashing the SD Card do nothing else then booting without any configuration. To reduce side effects I suggest to use first Raspbian Stretch Lite 2018-06-27 just for testing. With ip link show you must see at least one wifi interface, the one from the build in wifi chip, mostly named wlan0. You can also look if the wifi interface is blocked with (for example output from my RPi3B+):

rpi ~$ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

If the wifi interface is soft blocked you can enable it with rfkill unblock 0 (look at man rfkill). Hard blocked interfaces cannot be unblocked this way.

If you do not see any wifi interface, it's very likely that you have a hardware problem.

2
  • rfkill list shows nothing. I guess I have hardware problems. Fuck, now I can throw my first RPI away.
    – Stefan
    Oct 4, 2018 at 14:07
  • Already bought a new one. New one works fine.
    – Stefan
    Oct 4, 2018 at 14:07
0

To aid in resolving the issue use this resource

https://linux.die.net/man/8/wpa_supplicant

In "examples"

wpa_supplicant -c/etc/wpa_supplicant.conf -iwlan0 -d

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.