0

TL;DR: (Scroll down to bottom two questions)

I have found dozens of "solutions" on the Raspberry Pi 3B which have worked for people and not with my 3B+.

I suspect that there is a very specific problem with the "+" version, due to Ubuntu's wiki (https://wiki.ubuntu.com/ARM/RaspberryPi) stating:

Raspberry Pi 3 B+ (2018) functionality is not yet available with these images.

Raspberry Pi 3: ubuntu-18.04-preinstalled-server-armhf+raspi3.img.xz (4G image, 296M compressed) Updated 2018-04-28 (18.04 LTS)

Raspberry Pi 3: ubuntu-16.04-preinstalled-server-armhf+raspi3.img.xz (4G image, 252M compressed) Updated 2018-04-21 (16.04.4 LTS)

I have followed numerous guides on the 3B and a few guides specific to the 3B+ (not the 3B) and none of them have worked. I have flashed several "special 3B+" images onto my SD card and nothing works.

I have tried three different brands of cards, a total of 10 cards. I have tried four different USB power adapters ranging from 0.5A to 3.5A.

The furthest I have gotten is constant rainbow screen, although 90% of the time there was no HDMI signal (100% failure with the latest firmware from GitHub, which is really confusing to me).

As for the other indicators: Red light is constantly on (when powered). No other indicators on the Pi. When I did plug other devices in: Keyboard does not light up (even on powered USB splitter), LAN lights both dimly lit but DHCP never sees anything in that port.

I literally have setup two virtual machines to assist in my efforts, I have compiled all kinds of different projects including the u-boot for ARM in both 32 and 64-bit.

After spending two days (over 30 hours) working on this, I come with two questions:

1: Is it possible to get Ubuntu Server (64 bit) onto my Raspberry Pi 3B+?

2: If so, what are the specific steps?

I would really appreciate any help - I usually do not have problems like this.

  • And yes once I get it working, I will post the specific steps here - I will try to upload any hard-to-find files (e.g: uboot arm64) for anyone else to reuse as desired – theComputerProgrammer Oct 3 '18 at 6:39
  • 1
    functionality is not yet available with these images - perhaps eventually the good folks at Ubuntu will get things working with 3B+ - maybe in 18.10? – Jaromanda X Oct 3 '18 at 12:27
1

Since the release of Raspberry Pi 3B+ in March 2018 it seems that Ubuntu does not update it images with the new drivers the new hardware need. Look also at Why am I getting a rainbow screen and flashing red PWR LED with a new Raspberry Pi 3B+?. Obviously Ubuntu does have much interest to support Raspberry Pi. You should consider to change the operating system. I suggest to use Raspbian. It is also based on Debian like Ubuntu and it is the operating system official supported for the Raspberry Pi.

  • However they appear to have no intention of providing a 64-bit Debian. Only 32-bit. – Mark Adler Jan 8 at 3:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.