1

I have installed Raspbmc and audio worked fine via HDMI with no additional changes.

Now I have added a Bose Companion 5 speaker set to it, and can detect the sound card following the similar procedure:

pi@raspbmc:~$ cat /proc/asound/cards
 0 [Audio          ]: USB-Audio - Bose USB Audio
                      Bose Corporation Bose USB Audio at usb-bcm2708_usb-1.3, full speed

Unfortunately 29 pages of Q&A didn't get me much further (many stories but no convergence towards a successful method).

  • I have attempted to remove pulseaudio. No success.
  • I attempted to adjust alsamixer. No effect.
  • I tried to change modprobe.d using sudo nano /etc/modprobe.d/alsa-base.conf setting options snd-usb-audio index=0. No effect.
  • I have reinstalled pulse audio. No effect.
  • The Pi' has plenty of power available, and the bose USB is powered anyway.
  • The Bose companion 5 is on and there is a subtle static coming out of the speakers at max volume.
  • Kate Beckinsale's is visibly talking on the screen (Whiteout running in the background).

But no sound via the USB.

Does anybody have an idea of how to troubleshoot this, so I can get the image out via HDMI and audio out via USB?

I have also checked the loaded modules using lsmod, which returns the following:

pi@raspbmc:~$ lsmod
Module                  Size  Used by
bcm2708_wdog            2740  1 
ipv6                  232892  30 
xt_state                 660  1 
iptable_mangle           736  0 
iptable_nat             2408  0 
nf_nat                 10526  1 iptable_nat
nf_conntrack_ipv4       8768  4 nf_nat,iptable_nat
nf_defrag_ipv4           716  1 nf_conntrack_ipv4
nf_conntrack           51300  4 nf_nat,xt_state,iptable_nat,nf_conntrack_ipv4
iptable_filter           616  1 
ip_tables              10480  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               10436  5 ip_tables,xt_state,iptable_filter,iptable_mangle,iptable_nat
snd_usb_audio          94612  1 
snd_usbmidi_lib        24056  1 snd_usb_audio
snd_rawmidi            15764  1 snd_usbmidi_lib
snd_hwdep               3900  1 snd_usb_audio
snd_pcm                58784  1 snd_usb_audio
snd_page_alloc          2976  1 snd_pcm
snd_timer              17448  1 snd_pcm
spidev                  3932  0 
snd                    40140  8 snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib
spi_bcm2708             4380  0 
i2c_bcm2708             2872  0 
i2c_core               20536  1 i2c_bcm2708

I unplugged the USB cable to the Bose Companion 5 and rebooted. After reboot lsmod returns the following:

pi@raspbmc:~$ lsmod
Module                  Size  Used by
bcm2708_wdog            2740  1 
ipv6                  232892  30 
xt_state                 660  1 
iptable_mangle           736  0 
iptable_nat             2408  0 
nf_nat                 10526  1 iptable_nat
nf_conntrack_ipv4       8768  4 nf_nat,iptable_nat
nf_defrag_ipv4           716  1 nf_conntrack_ipv4
nf_conntrack           51300  4 nf_nat,xt_state,iptable_nat,nf_conntrack_ipv4
iptable_filter           616  1 
ip_tables              10480  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               10436  5 ip_tables,xt_state,iptable_filter,iptable_mangle,iptable_nat
spidev                  3932  0 
spi_bcm2708             4380  0 
i2c_bcm2708             2872  0 
i2c_core               20536  1 i2c_bcm2708

I then re-insert the usb cable and do a lsmod:

pi@raspbmc:~$ lsmod
Module                  Size  Used by
snd_usb_audio          94612  1 
snd_usbmidi_lib        24056  1 snd_usb_audio
snd_rawmidi            15764  1 snd_usbmidi_lib
snd_hwdep               3900  1 snd_usb_audio
snd_pcm                58784  1 snd_usb_audio
snd_page_alloc          2976  1 snd_pcm
snd_timer              17448  1 snd_pcm
snd                    40140  8 snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib
bcm2708_wdog            2740  1 
ipv6                  232892  30 
xt_state                 660  1 
iptable_mangle           736  0 
iptable_nat             2408  0 
nf_nat                 10526  1 iptable_nat
nf_conntrack_ipv4       8768  4 nf_nat,iptable_nat
nf_defrag_ipv4           716  1 nf_conntrack_ipv4
nf_conntrack           51300  4 nf_nat,xt_state,iptable_nat,nf_conntrack_ipv4
iptable_filter           616  1 
ip_tables              10480  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               10436  5 ip_tables,xt_state,iptable_filter,iptable_mangle,iptable_nat
spidev                  3932  0 
spi_bcm2708             4380  0 
i2c_bcm2708             2872  0 
i2c_core               20536  1 i2c_bcm2708

To me it seems like the kernel modules are loaded correctly.

Update: When unplugging the USB cable and rebooting the list of kernel modules contains (lsmod):

pi@raspbmc:~$ lsmod
Module                  Size  Used by
ipv6                  232892  18 
xt_state                 660  1 
iptable_mangle           736  0 
iptable_nat             2408  0 
nf_nat                 10526  1 iptable_nat
nf_conntrack_ipv4       8768  4 nf_nat,iptable_nat
nf_defrag_ipv4           716  1 nf_conntrack_ipv4
nf_conntrack           51300  4 nf_nat,xt_state,iptable_nat,nf_conntrack_ipv4
iptable_filter           616  1 
ip_tables              10480  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               10436  5 ip_tables,xt_state,iptable_filter,iptable_mangle,iptable_nat
spidev                  3932  0 
spi_bcm2708             4380  0 
i2c_bcm2708             2872  0 
i2c_core               20536  1 i2c_bcm2708

When I insert the USB cable the list of kernel modules contains (lsmod) with snd modules at the top:

pi@raspbmc:~$ lsmod
Module                  Size  Used by
snd_usb_audio          94612  1 
snd_usbmidi_lib        24056  1 snd_usb_audio
snd_rawmidi            15764  1 snd_usbmidi_lib
snd_hwdep               3900  1 snd_usb_audio
snd_pcm                58784  1 snd_usb_audio
snd_page_alloc          2976  1 snd_pcm
snd_timer              17448  1 snd_pcm
snd                    40140  8 snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_rawmidi,snd_usbmidi_lib
bcm2708_wdog            2740  1 
ipv6                  232892  30 
xt_state                 660  1 
iptable_mangle           736  0 
iptable_nat             2408  0 
nf_nat                 10526  1 iptable_nat
nf_conntrack_ipv4       8768  4 nf_nat,iptable_nat
nf_defrag_ipv4           716  1 nf_conntrack_ipv4
nf_conntrack           51300  4 nf_nat,xt_state,iptable_nat,nf_conntrack_ipv4
iptable_filter           616  1 
ip_tables              10480  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               10436  5 ip_tables,xt_state,iptable_filter,iptable_mangle,iptable_nat
spidev                  3932  0 
spi_bcm2708             4380  0 
i2c_bcm2708             2872  0 
i2c_core               20536  1 i2c_bcm2708
  • I had connected my pi to my TV and my stereo. But the audio was coming though the HDMI to the TV. To force it to go to the audio jack, I had to run sudo amixer cset numid=3 1 (where 1 is for the audio jack (0 is for hdmi)). You might need to do something similar. – Gerben Aug 12 '13 at 13:25
  • I have exactly the same setup - Companion 5 with Rasbmc. I was able to get the speakers 'working' using a nightly < 12.2 (refer Sam Nazario's answer). I could hear sound that was playing. The audio was out of sync with the video. There was so much stutter and lag in the audio that it was no use even for listening to music.(This is mentioned as an issue with AudioEngine in the nightly on the forum or somewhere, but I wanted to try it out anyway.) It did not work consistently across opening multiple files and reboots. Not really useful if you want it for use, you could try it if you just want to – chinchin Dec 9 '13 at 4:12
1

Using a USB DAC requires PulseAudio and the AudioEngine to be used, which aren't available in standard Raspbmc XBMC builds.

For DAC support, install a nightly < Frodo 12.2, i.e. 12.1 build from April. This will allow you to enable audio engine via Raspbmc Settings.

Plans are underway to get PulseAudio running on Pi again, however some work is needed.

  • ok. I'll update the post when Frodo becomes mainstream – root-11 Sep 5 '13 at 13:01
0

IIRC there's a sound device selection in XBMC itself.
http://wiki.xbmc.org/index.php?title=AudioEngine/HOW-TO:_Configure_audio

Should be able to set that to your USB sound device.

  • 1
    Nice idea, but no combination appeared successful. Any other ideas? – root-11 Aug 12 '13 at 20:32
  • 1
    In that case, unplug your USB sound card, reboot, do a lsmod and take note of all the modules that are loaded, rmmod all the sound ones, plug in usb sound card, do another lsmod, and take note of all the modules, and the ones that have not been reloaded, blacklist them. The ones that were not reloaded would probably be the ones that are for the onboard sound. – Lawrence Aug 13 '13 at 1:32
  • I have done as you suggested (thx) but can't recognize any snd modules that do not belong there. Am I missing something? – root-11 Aug 13 '13 at 18:20
  • Can you paste the lists of modules after you reboot with the USB Sound card unplugged, and point out the ones you unloaded ? – Lawrence Aug 14 '13 at 6:19
  • Added at the bottom :-) – root-11 Aug 14 '13 at 6:42
0

I had the same problem and got it to work once by sudo nano /etc/modprobe.d/alsa-base.conf and putting a # infront of options snd-usb-audio index=0.

After a reboot the USB Audio suddently worked. I have a stick usb audio in my usb hub.

I used an image http://www.raspberrypi.org/phpBB3/viewtopic.php?f=38&t=50543

And this link also helped me a lot.

http://lifehacker.com/5978594/turn-a-raspberry-pi-into-an-airplay-receiver-for-streaming-music-in-your-living-room

But then I deleted some files and I get reproduce this anymore making the same steps. Did somebody got it to work yet?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.