0

I try to quietly boot into a qt app on a raspberry 3 running raspian stretch. In my /boot/cmdline.txt I have

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty3 root=PARTUUID=02e50ed3-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet  loglevel=0 logo.nologo vt.global_cursor_default=0 splash plymouth.ignore-serial-consoles

with a custom plymouth splash screen. My qt app is started via systemctl (with WantedBy=multi-user.target in its .service file). Everything works nearly perfectly, but before my app is running, for approximately two seconds the console prompt

pi@raspberry:~/

is displayed above the plymouth splash screen. How can I remove it?

2

The service getty@tty1.service is responsible for this.

Try

systemctl disable getty@tty1.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.