0

This is the error that I’m getting in etcher.

enter image description here

I've also tried the macOS disk utility tool to restore it but I'm getting errors there too. The error message is German but it says something like the volumes image list couldn’t be retrieved - OSStatus 45.

Also I've tried two images from different dates both were created using disk utility create image.

I’d really like to restore my image because otherwise I’ll have to setup my pi again from ground up.

EDIT: here is the text version of the error message (used OCR to generate it, so there may be a typo)

Invalid typed array length

RangeError: Invalid typed array length
    at Buffer.Uint8Array        (native)

    at FastBuffer               (buffer.js:11:5)
    at createUnsafeBuffer       (buffer.js:37:10)
    at Function.Buffer.alloc    (buffer.js:141:12)

    at ReadStream._read         (/Applications/Etcher.app/Contents/Resources/app.asar/node_modules/udif/lib/readstream.js:128:25)
    at ReadStream._read         (/Applications/Etcher.app/Contents/Resources/app.asar/node_modules/udif/lib/readstream.js:100:19)
    at ReadStream._read         (/Applications/Etcher.app/Contents/Resources/app.asar/node_modules/udif/lib/readstream.js:106:19)
    at ReadStream._read         (/Applications/Etcher.app/Contents/Resources/app.asar/node_modules/udif/lib/readstream.js:118:21)

    at ReadStream.Readable.read (/Applications/Etcher.app/Contents/Resources/app.asar/node_modules/readable-stream/lib/_stream_readable.js:436:10)
    at flow                     (/Applications/Etcher.app/Contents/Resources/app.asar/node modules/readable-stream/lib/_stream_readable.js:806:34)
    at Pipeline.<anonymous>     (/Applications/Etcher.app/Contents/Resources/app.asar/node modules/readable-stream/lib/_stream_readable.js:676:7)

    at emitNone                 (events.js:86:13)
    at Pipeline.emit            (events.js:188:7)

    at onwriteDrain             (_stream_writable.js:393:12)
    at afterWrite               (_stream_writable.js:381:5)
    at onwrite                  (_stream_writable.js:374:7)
  • How exactly did you create the image? – Dirk Oct 4 '18 at 22:03
  • did you try a different SD card? – jsotola Oct 5 '18 at 2:40
  • @Dirk "create image" in Disk Utility – Alexander Hoerl Oct 5 '18 at 5:24
  • @jsotola yeah I’ve tried a new one as well, also the card was working fine until know. – Alexander Hoerl Oct 5 '18 at 5:25
  • I don't know disk utility. Does it create images compatible with Etcher, etc? – Dirk Oct 5 '18 at 6:13
0

The problem was that the image was created using macOS disk utility and it doesn't like Linux images. If you want to create Linux images use dd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.