1

When ever i run apt-get install with openssl or libssl-dev i get the following error

After this operation, 10.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'vim-tiny' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

i cannot figure out what this means or how to fix it. any suggestions?

  • what does the output of cat /var/lib/dpkg/info/vim-tiny.list look like? – Jaromanda X Oct 6 '18 at 4:08
  • The file appears to be empty – Tomer Shemesh Oct 6 '18 at 13:56
  • Well that's not right – Jaromanda X Oct 6 '18 at 14:06
  • i think i fixed it. just deleted the file, updated and forced reinstall of vim-tiny – Tomer Shemesh Oct 6 '18 at 14:11
0

In the end I just deleted /var/lib/dpkg/info/vim-tiny.list and reinstalled vim-tiny.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.