0

i'm new at RPi. Today, i installed NOOBS and tried to turn on Wi-Fi. When i clicked network icon (next to the bluetooth icon), it written "no wireless interfaces found".

I typed to terminal "sudo ifconfig". There is no wlan0. I edited wpa_supplicant.conf, it didn't change anything. I tried to change wifi country code on raspi-config but "no wireless interface found","There was an error running option I4 Change Wi-Fi Country" errors showed up. So what should i do?

  • I asked the one that used this device before. He is not sure, he encountered with some errors about it – YunusEryilmaz18 Oct 6 '18 at 19:12
  • try a different image - raspbian (full or lite) - I know NOOBS is supposed to be "easy", but it seems it's easily broken – Jaromanda X Oct 7 '18 at 3:08
3

In a console with ip link show you should always see an interface for wifi, mostly wlan0, no matter if wifi works or not. if not, it is likely that you have a hardware problem. Look at After fresh Raspbian-Stretch install my WiFi isn’t working on my Raspberry Pi 3 anymore for further information. To narrow down the problem you my consider only for testing to install Raspbian Stretch Lite 2018-06-27. It does not need much resources and may reduce side effects in configuring wifi.

  • it seem broken, just showed up eth. Thanks for your answers. – YunusEryilmaz18 Oct 13 '18 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.