1

I have successfully run a webserver and a wordpress site in a raspberry pi3 and I am trying to get the raspberry pi to broadcast itself as an access point, so the plan is I want to connect to the raspberry and without any internet network at all.

the target is when I access the raspberry accesspoint and I type in my laptop browser : raspberrypi.local it will load the webserver?

is that possible? and I tried modifying the virtualhost on apache2 in pi but after restart I tried directly on pi desktop the virtualhost are not working at all

any references would be great thank you!

  • 1
    almost like you want a captive portal – Jaromanda X Oct 8 '18 at 11:19
  • I found an article describing what you want to achieve (but only in german) heise.de/-3851689 – Uwe Plonus Oct 8 '18 at 11:47
  • @JaromandaX I am not looking for captive portal, I wanted to put screen running on wordpress raspberry (which wordpress is already running), and the problem is getting the laptop to connect to the raspberry via the laptop browser and interact with the wordpress system only, like accessing a webpage but this is locally done – Boby Oct 8 '18 at 12:16
  • @UwePlonus - that describes a captive portal - so, not what the OP asks for - he wants to have the Pi set up as an access point, and be able to connect his laptop to the Pi access point, and be able to access, using his browser, the web server on the raspberry pi ... oh, wait ... a captive portal – Jaromanda X Oct 8 '18 at 12:19
  • @UwePlonus I read the article you posted and yes its similar but its running into like a hotspot webpage, instead can I like when accessing the pi from browser for example like raspberrypi.local, it will open up the wordpress site in the raspberry – Boby Oct 8 '18 at 12:20
1

after days of research and testing, turns out the best choice I have is not to install a captive player, but instead my solutions was to 1st do a pi access point setup with the capabilities of bridge internet : following this article:

pi access point setup

then 2nd I setup the hostname with the webserver and allowing ssh and when I access the pi access point, I can browse the webserver in the access point and DONE! problems solved :)

hopefully this one can help someone who need this info

  • thanks for providing the solution to your problem. you should be able to mark it as accepted now. – Piotr Kula Feb 26 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.