0

My PI-3B is flashed with Ubuntu 16.04 with wireless-tools and wpa_supplicant also installed.

My issue is I can't get wlan0 to be recognised by the system either dynamically (DHCP) or statically.

I am using the following config data in /etc/network/interfaces:

source-directory /etc/network/interfaces.d
source /etc/network/interfaces.d/*.cfg

auto wlan0
#iface wlan0 inet dhcp
iface wlan0 inet static

address 192.168.0.40
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
dns-nameservers 192.168.0.1, 8.8.8.8

wpa-wssid WIFI-NETWORK-NAME
wpa-psk WIFI-NETWORK-PASSWORD

TO ELIMINATE HARD ISSUES, On the same Pi, but with a different SD card flashed with Raspbian, wifi connection works with the following settings in /etc/network/interfaces:

allow-hotplug wlan0
iface wlan0 inet manual
   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

So, the issue does not seem to be hardware related.

Can anyone help, please?

0

It is not entirely clear what you are using - "Ubuntu 16.04" is ambiguous, I am assuming the version of Ubuntu MATE linked from the Foundation site.

  1. Ubuntu uses predictable network interface names so WILL NOT have wlan0 (this may not apply to Pi3 as onboard WiFi chip is connected by sdio)

  2. Ubuntu uses NetworkManager which DOES NOT use /etc/network/interfaces

If you want to use Ubuntu configure it through the GUI - the way it is designed to work.

You DO NOT need to install any tools to make it work, and attempting to do so may interfere with other pre-installed software.

PS The settings you listed for Raspbian are OBSOLETE. See How to set up networking/WiFi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.