1

I have set up a clean boot on a Pi with Stretch Lite and set it up so that it disables displaying text during boot and shows a Plymouth splash screen. One of the commands in /boot/cmdline.txt is "vt.global_cursor_default=0" which disables the blinking cursor during bootup. I have disabled auto-login so the terminal starts up with a login prompt. Because of the cmdline option, there is no blinking cursor. How do I enable the blinking cursor automatically after boot completes so that it blinks on the login prompt?

I added "setterm -cursor on" in ~/.profile which starts the blinking cursor after login, but I'd like it to start before login.

I tried modifying /etc/systemd/system/autostart@.service, but that didn't help.

ExecStart=-/sbin/agetty -I "\033[?2c"  %I $TERM

Here's my new /boot/cmdline.txt

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=117966a4-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait logo.nologo quiet splash vt.global_cursor_default=0

Edited to clarify.

  • I do not understand what you are doing. When I flash Raspbian Stretch Lite and boot it in my RasPi I get a login prompt on a virtual console. There is no graphics available. What is everything to disable on Stretch Lite? There is not much not essential to disable. – Ingo Oct 12 '18 at 9:19
  • My point is that I have customized the boot to show my own splash on boot up. Part of that customization is to disable the cursor so it doesn't flash over the top of my splash image. The problem is, once disabled, I don't know how to automatically re-enable after boot is completed and its ready to log in. Using .profile is too late, because that's after login. I haven't figured out what needs to be in rc.local to show a blinking cursor on the login prompt. I updated the question to clarify a bit. – Ed K Oct 12 '18 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.