0

I'm stuck with this Adafruit module. I was able to install without errors on a Pi2, but when I tried to replicate on my Zero W the installation goes fine but then I cannot import the module ("Adafruit_Nokia_LCD module not find").

Raspian Strech in installed on both of them.

I installed the module with sudo python setup.py install, which gives the following output (I'm reinstalling it).

pi@WRM:~ $ sudo python Adafruit_Nokia_LCD/setup.py install
    running install
    running bdist_egg
    running egg_info
    writing requirements to Adafruit_Nokia_LCD.egg-info/requires.txt
    writing Adafruit_Nokia_LCD.egg-info/PKG-INFO
    writing top-level names to Adafruit_Nokia_LCD.egg-info/top_level.txt
    writing dependency_links to Adafruit_Nokia_LCD.egg-info/dependency_links.txt
    reading manifest file 'Adafruit_Nokia_LCD.egg-info/SOURCES.txt'
    writing manifest file 'Adafruit_Nokia_LCD.egg-info/SOURCES.txt'
    installing library code to build/bdist.linux-armv6l/egg
    running install_lib
    warning: install_lib: 'build/lib.linux-armv6l-2.7' does not exist -- no Python modules to install

    creating build/bdist.linux-armv6l/egg
    creating build/bdist.linux-armv6l/egg/EGG-INFO
    copying Adafruit_Nokia_LCD.egg-info/PKG-INFO -> build/bdist.linux-armv6l/egg/EGG-INFO
    copying Adafruit_Nokia_LCD.egg-info/SOURCES.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
    copying Adafruit_Nokia_LCD.egg-info/dependency_links.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
    copying Adafruit_Nokia_LCD.egg-info/requires.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
    copying Adafruit_Nokia_LCD.egg-info/top_level.txt -> build/bdist.linux-armv6l/egg/EGG-INFO
    zip_safe flag not set; analyzing archive contents...
    creating 'dist/Adafruit_Nokia_LCD-0.2.0-py2.7.egg' and adding 'build/bdist.linux-armv6l/egg' to it
    removing 'build/bdist.linux-armv6l/egg' (and everything under it)
    Processing Adafruit_Nokia_LCD-0.2.0-py2.7.egg
    Removing /usr/local/lib/python2.7/dist-packages/Adafruit_Nokia_LCD-0.2.0-py2.7.egg
    Copying Adafruit_Nokia_LCD-0.2.0-py2.7.egg to /usr/local/lib/python2.7/dist-packages
    Adafruit-Nokia-LCD 0.2.0 is already the active version in easy-install.pth

    Installed /usr/local/lib/python2.7/dist-packages/Adafruit_Nokia_LCD-0.2.0-py2.7.egg
    Processing dependencies for Adafruit-Nokia-LCD==0.2.0
    Searching for Adafruit-GPIO==1.0.3
    Best match: Adafruit-GPIO 1.0.3
    Processing Adafruit_GPIO-1.0.3-py2.7.egg
    Adafruit-GPIO 1.0.3 is already the active version in easy-install.pth

    Using /usr/local/lib/python2.7/dist-packages/Adafruit_GPIO-1.0.3-py2.7.egg
    Searching for spidev==3.2
    Best match: spidev 3.2
    Processing spidev-3.2-py2.7-linux-armv6l.egg
    spidev 3.2 is already the active version in easy-install.pth

    Using /usr/local/lib/python2.7/dist-packages/spidev-3.2-py2.7-linux-armv6l.egg
    Searching for Adafruit-PureIO==0.2.3
    Best match: Adafruit-PureIO 0.2.3
    Processing Adafruit_PureIO-0.2.3-py2.7.egg
    Adafruit-PureIO 0.2.3 is already the active version in easy-install.pth

    Using /usr/local/lib/python2.7/dist-packages/Adafruit_PureIO-0.2.3-py2.7.egg
    Finished processing dependencies for Adafruit-Nokia-LCD==0.2.0

So seems everything ok, like the package is installed and available, but when I try to recall it on python shell...

pi@WRM:~ $ python
>>  import Adafruit_Nokia_LCD
>>  ImportError: No module named Adafruit_Nokia_LCD

On the first output there's a warning about a missing folder (precompiled libraries?), could be a hint about my situation?

The module is present on the right folder: (no prob importing GPIO module)

ls /usr/local/lib/python2.7/dist-packages/
Adafruit_GPIO-1.0.3-py2.7.egg       easy-install.pth
Adafruit_Nokia_LCD-0.2.0-py2.7.egg  spidev-3.2-py2.7-linux-armv6l.egg
Adafruit_PureIO-0.2.3-py2.7.egg

On the Pi2 the module works like a charm.

Suggestions? Thanks.

0

As suggested here: "ImportError: No module named 'gspread'"

Solved using 'pip install Adafruit_Nokia_LCD/.'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.