I have a Raspberry Pi Rev 3 Model B. I have used Tera Term's SSH to connect to my Pi many times in the past, although when I tried to connect yesterday it was the first time I had tried in about a month. I tried the 5 steps in SSH - connection timeout when connecting to verify that the Raspberry Pi could SSH to itself. When I tried to connect from my laptop, the screen just remained black: enter image description here

Oddly enough, if I attach a monitor to the Pi and use the Pi to ssh itself via "ssh" it is able to connect and it also recognizes that the last login was from my laptop IP. If I purposely enter a wrong password from my laptop it also rejects that attempt, leading me to believe that there is actually a connection to the Pi. My Pi is the, laptop is

I have also tried using Putty. With both Tera Term and Putty, eventually I am able to connect: enter image description here

Despite connecting, when I try to send commands they do not act like I expect. For example, I tried to just go to the desktop by doing "cd Des" followed by a tab to complete Desktop. It seems as though the cursor moved as if the line was completed, but the directory didn't appear to change. While grabbing the screenshot the connection also shut down while idling, nothing seemed to change on the Pi's monitor. enter image description here

I swapped to my desktop and was immediately able to connect, but there was a strange echo despite using the same settings I was accustomed to:enter image description here

After rebooting the Pi I connected from my laptop again. The weird echo from below happened when typing "cd Desk" + tabenter image description here

I tried reinstalling a fresh version of Raspbian using NOOBS, but the problem is still there.

What could cause the Pi's SSH to:

  1. Randomly be able to successfully be connected to from other PCs
  2. Have odd echoes from text input
  3. Ignore some commands (i.e. ls after I manage to successfully change directories)
  • If you have already tried re-installing the RPi, the issue may be with your laptop (IE: The computer you are connecting from). Do you have access to another computer to try SSH into the RPi?
    – Vincent P
    Oct 12, 2018 at 6:19
  • Yes, I've tried it on both my laptop and desktop with similar results. My laptop was also able to connect without any problems about a month ago, then I left my RPi sitting unplugged for a while Oct 12, 2018 at 6:39
  • I rebooted the RPi and connected from my desktop and things seemed to work normally again. I rebooted the RPi again and there was about a 15 second delay between typing and when the characters would show up, and after about a minute my Tera Term session closed itself Oct 12, 2018 at 6:46
  • If you add the /ssh-v option, the protocol debugging messages may give a clue about what the failure might be when attempting to connect... for information about how to use the options from the command line, see the documentation Oct 12, 2018 at 22:18
  • Thank you for the suggestion. I decided to use the Putty log file since it seems easier for me. I can see the raw hex data going out and coming in (and the ASCII interpretation). I haven't encountered the issue where I can't log in or the echoing, but I am still encountering the issue with extreme lag around inputs. Although nothing glaringly obvious is sticking out as the cause I will continue using this new tool. I also expect a new raspberry pi to arrive this weekend and will compare the log files between this troublesome unit and the new one Oct 13, 2018 at 1:55


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.