3

I am accessing my Pi through SSH and I noticed that I cannot mkdir anywhere. not even in my own home folder ~/!! Unless I sudo.

I checked the owner and permission of my folder. it is as follow:

drwxrwxrwx 9 pi pi 4096 Aug 13 10:22 pi

everything is owned by me, and I even chmod 777 it just for this once. But still I get mkdir: cannot create directory x': No space left on device error when I try to mkdir

Obviously there is space left on device because everything works fine if i put sudo in front of it. So what is the problem here ?

  • 3
    Try to use df -h to see how much space is left on your device. – Kenneth Aug 13 '13 at 13:34
  • I should add: raspbian comes with utility to expand partition to fill the entire SD card. – 40Plot Nov 30 '15 at 3:54
6

It's not a problem for root. Because on ext filesystems 'root' user has extra %5 reserved space on filesystem while formatting. If that reserved space filled up you will not create file/dir on filesystem neither. Delete some files on your filesystem to get free space.

3

For those with similar problem, make sure to run raspberry pi config tool. In there you will find a menu that allows you to expand your partition to fill 100℅ of the available space. Otherwise, you will be limited to very small space regardless of your SD card size.

  • 1
    Good advice! The tool is run with: sudo raspi-config – adengle Jan 17 '16 at 13:02
-1

good advice. from UI you need to do following things 1. Go to Menu 2.select preferences 3. raspberry pi configuration 4. system tab 5. Expand fileSystem. 6. Reboot your Pi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.