1

I'm having a hard time installing the wiring-pi node package. It fails on the step "Making wiring-pi ...", spaming the terminal with build errors.

If I clone and install wiring-pi manually as described here, it works just fine. Also, I could not find any incompatibilies on the official repo.

System:

  • node v10.12.0
  • npm 6.4.1
  • Raspbian GNU/Linux 9.4 (stretch)
  • Release: 9.4

Any suggestion what is wrong? Thanks in advance!

  • Exactly which package did you install? What errors do you get? Did you install the necessary prerequisites (if any)? – Dirk Oct 13 '18 at 14:45
  • package wiring-pi (as I said?), errors are mostly spam (uploaded here: github.com/BernhardSchlegel/stackoverflow/blob/master/…), no prereqquisites (npm should take care of). – Boern Oct 13 '18 at 16:08
  • The 'spam' conntains 49 error msgs. Mostly ` error: ‘class v8::Object’ has no member named ‘ForceSet’`. Search suggests a node version compatibility issue. – Dirk Oct 13 '18 at 16:58
  • I was suspecting a version problem, and tried to downgrade node - witouth success. And as I couldn't find any officlal compatibility list, I thought maybe the problem is elsewhere – Boern Oct 13 '18 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.