1

I was able to use the Pi as a Midi synthesizer for a Midiplus AKM320 controller using fluidsynth and aconnect. Then I got a larger Roland A49 midi keyboard, but am unable to get this to work. It shows up with lsusb:

Bus 001 Device 004: ID 0582:0156 Roland Corp.

It has no strange dmesg output:

[    3.261803] usb 1-1.3: new full-speed USB device number 4 using dwc_otg
[    3.377288] usb 1-1.3: New USB device found, idVendor=0582, idProduct=0156
[    3.386801] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.396664] usb 1-1.3: Product: A-Series Keyboard
[    3.403869] usb 1-1.3: Manufacturer: Roland

Problem is that it does NOT show up with aconnect -i.

The Roland still works with Ubuntu on my laptop.

About my Raspberry Pi:

$ uname -a
Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l GNU/Linux
$ cat /etc/issue
Raspbian GNU/Linux 7

How do I get this Roland keyboard to work?

(Disclaimer: I am not affiliated with the manufacturer with the same name)


update:

Looking at this SO question I tried to load module snd-seq-midi, but it made no improvement.

This midi keyboard is not listed in /proc/asound/cards and neither by amidi -l .

  • Is the snd-usb-audio module loaded? – CL. Oct 14 '18 at 8:16
  • @CL. Good question! It is loaded by the AKM320, but not with the Roland. I loaded it with modprobe, which also loaded modules snd_hwdep, snd_usbmidi_lib, snd_pcm and snd. But the Roland is still not recognized with aconnect -i – Roland Oct 14 '18 at 14:10
  • Any messages in the system log when you're loading it? – CL. Oct 14 '18 at 18:53
1

According to the answer on a differently phrased question of me here, the solution is to upgrade to the current version of the raspberry pi linux. Support for this Roland keyboard was not yet in the kernel version of 2013. I just upgraded to the current version of Rasbian and now the Roland is recognized by aconnect -i.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.