-1

I have successfully created and access point to my local rapsberry pi 3 and I was able to connect the pi AP without internet with my iphone and when I open the browser and hit the raspberrypi.local it shows the webbrowser with the static html I created.

but when I try to connect using the android phone, it never connects to the network and it fails, so I tried using static ip to the android phone where I found out that my pi ip is 169.254.10.244 and I setup the android wireless connect to use static ip where the ip is 169.254.10.245

and the android now can connect to the pi access point, but when I try to browse using chrome in my android hitting the raspberrypi.local gave me no internet error page?

I am confused on how to solve this as my iphone connect without having to assign any ip address and when the browser was launch and the raspberrypi.local was entered it load just fine.

any issues on my my android phone are unable to connect to the pi access point? and have to serve on a static ip, and still it wont work?

would be great to work like how the iphone connects and just run

update : its setup under raspberry latest stretch - apache2

and access point setup via : https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

thank you

1

169.254.10.244 is NOT a static IP address it is a Link-local address and is not routable.

While macOS (and presumably iOS) allow some protocols to work over Link-local addresses this is NOT their intended purpose.

This probably indicates that however you "created an access point:" this is misconfigured.

  • is there anyway to work around this problem? do I have to assign a static ip? as I configured the bridge to inet manual @Milliways – Boby Oct 16 '18 at 6:03
  • @Boby without detail of what you have done any comment would be idle speculation. You haven't even mentioned what OS. Generally it is necessary to assign an IP to an Access Point, but there must be dozens of ways of setting up an AP. You should ask a new question about AP and describe what YOU have done. – Milliways Oct 16 '18 at 6:58
  • I updated the notes and I was using the basic raspberrypi.org/documentation/configuration/wireless/… install ap point with apache2 server configuration. – Boby Oct 16 '18 at 7:54
  • @Boby if you HAD actually done this it would work - obviously you did something else - so just posting a link doesn't help. NOTE UPDATE your question DON'T post detail in Comments. – Milliways Oct 16 '18 at 8:46
  • Following the tutorial you have linked to there is no way to fiddle with link-local addresses 169.254.0.0/16. The access point has 192.168.4.1 and with its DHCP server (dnsmasq) it will give ip addresses 192.168.4.2 to 192.168.4.20 to its stations (android phone, iphone). You should follow that tutorial. – Ingo Oct 17 '18 at 9:47
1

I have worked on this few months ago, and today, i figured out why this happens! The reason android phones fail to connect with Raspberry Pi's AP is that in android phones have a range of IPs in their "Developer Options". While connecting to RPi's AP on android phone, use static Ip in "Advanced Options" such as in my case the ip of AP is "169.254.208.226" so i will try to use any IP like i used "169.254.208.22", and voila, my android phone got connected...

Try this and thank me later...

New contributor
Abdullah 1998 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Why would you use a static IP in the 169.254.0.0/16 range? – RalfFriedl Dec 3 at 21:26
  • statis IP is set according to the IP that RPi broadcasts... – Abdullah 1998 Dec 4 at 6:09
  • 169.254.xxx.yyy/16 is the link-local address subnet block, used by systems to self assign an IP address when a DHCP server can't be contacted. It's not intended for use as a private address block. Use 10.xxx.yyy.zzz/8 or 172.[16-31].xxx.yyy/16 or 192.168.xxx.yyy/24 for your private networks. Most home NAT routers use 192.168.xxx.yyy/24 often 192.168.1.xxx/24 or 192.168.0.xxx/24. Microsoft ICS uses 192.168.137.xxx/24. You may want to avoid those pre-assigned subnet blocks. – Dougie Dec 4 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.