This is a follow up question to this post and subsequently this post.

To save you from a long read I am trying to force a MAC address change on my Pi Zero ethernet adapter with:

ifconfig eth0 down; ifconfig eth0 hw ether 21:21:21:21:00:11; ifconfig eth0 up; ifconfig eth0

But I receive the error message:

ether: Host name lookup failure
ifconfig: `--help' gives usage information.
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::bb7e:8c36:1a6c:4d5e  prefixlen 64  scopeid 0x20<link>
        ether 10:10:12:10:10:10  txqueuelen 1000  (Ethernet)
        RX packets 1342  bytes 95363 (93.1 KiB)
        RX errors 1  dropped 5  overruns 0  frame 1
        TX packets 817  bytes 102452 (100.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Why can I not find ether? Many additional details leading up to this point can be found in the linked questions if needed.

  • odd error - the 21:21:21:21:00:11 address in the question is not valid - because of the LSB set in the first byte of the MAC ... but I can see the MAC is 10:10:12:10:10:10 in the output - are you actually trying to set the address to 21:21:21:21:00:11? In a previous answer I suggested the safest MAC addresses raspberrypi.stackexchange.com/a/88936/33057 the first part being x2, x6, xA or xE Oct 16, 2018 at 22:04
  • Yeah I was trying to switch it to another address just to test the method again and happened to pick 21 arbitrarily. I also tried a MAC address starting with 99, is that also invalid?
    – Matt
    Oct 16, 2018 at 22:06
  • My mistake I should have followed your initial advice.
    – Matt
    Oct 16, 2018 at 22:08
  • 1
    any ODD number as the second digit i.e. 1,3,5,7,9,B,D,F will be invalid ... the 2,6,A,E in the list are the so called "locally administered" MAC addresses - not likely to clash with a manufacturer MAC address (whose second digits would be one of 0,4,8,C Oct 16, 2018 at 22:12
  • @JaromandaX even using 22:12:12:12:12:12 I receive the exact same error message
    – Matt
    Oct 17, 2018 at 0:22

1 Answer 1


I had forgotten an eth0 in ifconfig eth0 down; ifconfig eth0 hw ether 21:21:21:21:00:11; ifconfig eth0 up; ifconfig eth0

Additionally, as Jaromanda said - 21:21:21:21:00:11 is an invalid MAC address. The second digit of the MAC address ought to be 2, 6, A, or E, the locally administered addresses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.