0

I have a RPI Model B (Revision 000e) running stretch lite (command line only) and with up-to-date software and firmware. I would like to enable WiFi by using a Sitecom WLAN USB adapter (model wla2000).

When I plug in the WiFi adapter and reboot, the WiFi adapter seems to be recognized:

$ ip addr
(...)
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:0c:f6:c7:73:0f brd ff:ff:ff:ff:ff:ff

and

$ ifconfig
(...)
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:0c:f6:c7:73:0f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

However, I can not turn on the WiFi via any of these commands:

$ sudo ip link set wlan0 up
$ sudo ifconfig wlan0 up

When I try to set the WiFi legal channels via:

'$ sudo raspiconfig' -> '4 Localisation Options' -> 'I4 Change Wi-fi Country'

I get the error message:

Could not communicate with wpa_supplicant

The following is in my /etc/wpa_supplicant/wpa_supplicant.conf file:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

Any help is very much appreciated.

  • Unless you say what Pi (try using a standard name rather than inventing one) and what " updated software and firmware" means and network settings you are using it as anyones guess. You could start with How to set up networking/WiFi – Milliways Oct 16 '18 at 23:36
  • Maybe instead of being condescending you could first check some facts. (Model B, revision 000e is not an 'invented' name but perfectly indicates which board I am using - raspberrypi.org/documentation/hardware/raspberrypi/…). Furthermore, with updated firmware and software I mean that I ran rpi-update and sudo apt-get update and sudo apt-get upgrade before trying to get the WiFi adapter to work to indicate that obsolete firmware/software is not the issue here. – Vincent Oct 16 '18 at 23:52
  • I am sorry that you think this is "condescending" but your description leaves a lot to be desired - not to mention the contradictory title. The fact remains without detail of your network settings is unanswerable. – Milliways Oct 17 '18 at 0:24
  • wlan0: flags=4099<UP,BROADCAST,MULTICAST> ... it's already "UP" so you don't need to bring it UP any further. – Jaromanda X Oct 17 '18 at 1:57
1

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."

-1

I just went through (hell) similar experience trying to make internal WiFi to work.This should work for a USB dongle too - not tested.

Here is my take on the whole mess.

  1. Forget “official tutorials “ and “raspi-config”. ( “cannot communicate with wpa_supplicant “ is a joke )
  2. Make sure wpa_supplicant SERVICE is running. "wpa_cli" will start it, "Network Manager" may do same - not tested.
  3. With what WiFi device will your Rpi be communicating ? Router / modem?
  4. Use Raspi OS GUI “Network Manager” (sic?() to find “the other end of the communication link” - in my case router / modem.
  5. Select the device (name / SSID) and supply password if necessary.
  6. Reboot and test.

Of course your mileage will wary.

  • 2
    running stretch (command line only) - so your GUI things wont help :p – Jaromanda X Oct 17 '18 at 2:14
  • Yes, you can do it the hard way - using CLI - or use GUI and you are done! – Jan Hus Oct 17 '18 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.