I have direct connection with Raspberry pi via ethernet cable on linux machine. if i run ssh pi@ i could establish secure connection. the problem i encountered is raspberry hang or frozen anytime run ifconfig eth0 0or trying to bring bridge interface. similarly this problem persist with my other three (3)pi. have read much and no solution for this.

  • of course if you disable the ethernet port then the ethernet port wont be able to sustain an ssh connection - It's like if you wanted to change a light fitting, at night, with no torch or other means of lighting ... and complain that turning the light off at the main switch makes it dark – Jaromanda X Oct 17 '18 at 4:11
  • of course i agree with you. actually am running a mesh topology on raspberrys and all the interface interconnected to other raspberrypi i.e eth0, eth1, eth2, eth3, eth4 using usb ethernet adapter. the only way i can i start up an ovs is to ssh into pi eth0. although hang and frozen of the pi persist where Crt C dont even work. i tried sudo ifconfig br0 netmask up. still frozen. is there any method available to start up all the interfaces without hanging – IB Abdull Oct 17 '18 at 8:11
  • Do a script that runs all commands even when disconnecting. Include commands for bringing the interface back on-line when finished. Run script. Profit. OR use hdmi and a keyboard to attach the Pi to your TV, then type directly into the PI. Easier than the ethernet connection that you manually disconnect and can't re-establish. – svin83 Feb 9 '19 at 4:26

I don't know what you want to achieve but you are connected to the RasPi with ssh. That needs a configured and running interface, in your case eth0. If you reconfigure eth0 then the connection is broken and of course also your ssh connection.

There are several ways to don't cut the branch that carries you. Use a monitor on hdmi, use a TTL to USB adapter for the serial console, use a second interface only for ssh without touching its configuration, use a batch file that will bring back the interfaces, use systemd-networkd to activate configuration after reboot ...


Correct syntax for adding alias interface is ifconfig eth0:0 (with :). IP must be available and from the same subnet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.