1

While starting startx, I get error

  1. fatal error could not create lock file in /tmp/.tx0-lock

  2. error in locking authority file.

  3. Even I am unable to delete .Xauthority file

  • can you paste your disk usage output 'df -h' command? – gurcanozturk Aug 15 '13 at 11:10
  • May be a permissions problem. Try deleting as root. – Fred Mar 15 '14 at 12:24
3

After a simple Google search, I found this post. Take a look at the 2nd and 3rd comment for a possible solution.

According to @KnotMan33

Thank YOU my pi is now working!!

I didn't do anything but check my SD card usage with

    df -h

and then it ran Startx again and i worked!

I think that the Pi didn't recognize that there was space available until i ran df -h where it realized there was lots of extra space.

Thank you again!!!

  • 1
    would be more appropriate to include some quotes from the post just in case if the forum goes offline and renders your answer irrelevant. – lenik Aug 16 '13 at 2:50
-3

Run the command:

sudo raspi-config

Select 'Expand Filesystem'

Select 'Enable Boot to Desktop'

Select Finish, then reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.