0

since jessie has libdb5.3 which is incompatible with libdb4.8 how to install the latter. I added oldstable main contrib ... to the mirrordirector but no chance in finding it.

Where are the old packages located alias what to add to sources.list to get it apt found and install it libdb4.8 and libdb4.8++?

2

Seems you are trying to get the old libdb4.8 from a previous Raspbian version with oldstable version in /etc/apt/sources.list But this doesn't help much because you are really very outdated with your installation. You are using raspbian-jessie that is already oldstable. If you want to address the predecessor of jessie you must use oldoldstable, that is wheezy. You can also look at http://raspbian.raspberrypi.org/raspbian/ if you find libdb4.8 in one of the older Raspbian versions.

Btw. a simple search with libdb4.8 on google give me over 30,000 matches and just the first one from ubuntu shows where to get the library dev files:

sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update  
sudo apt-get install -y libdb4.8-dev libdb4.8++-dev

Maybe you will find also the library there. If not, then there are 30,000 other links.

And yes, you should really consider to upgrade your software to latest stable versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.