0

I'm trying to install a library to my RPi 3 B, but for some reason when I try to import it in my script, it won't recognize the library. This is the library:

https://github.com/widgetlords/libwidgetlords

And here are the install instructions:

https://widgetlords.com/pages/getting-started-with-pi-spi-libraries

When I perform the instruction:

from widgetlords.pi_spi import *

I get the error "No module found called widgetlords.pi_spi". I have tried installing manually, and also tried using the pip install instruction, but for some reason can not install this module properly. Any advice??

Thanks!

  • 1
    What is the output of the install command (the dpkg -i line). And is the module meant for Python 2 or Python 3? – Dirk Oct 30 '18 at 15:46
  • It is meant for Python 3. I realized this too so set python 3.5.5 to the default. I am still having trouble. Were you able to install the lib? – Djaenike Oct 30 '18 at 16:07
  • I'm not even trying. What about the output of the install command I asked about? Add it to your question. – Dirk Oct 30 '18 at 16:08
  • dpkg: error: cannot access archive 'libwidgetlords_1.0.2_armhf.deb': No such file or directory – Djaenike Oct 30 '18 at 16:19
  • 1
    Add it to your question – jsotola Oct 30 '18 at 20:39
1

Disregard. Was using Geany as the text editor which defaults to python 2. Changed it to python 3 which solved the issue

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.