4

When I try and do sudo apt-get update it seems to me that I have 4 newer packages than what is to be installed. Any help would be appreciated. Thank you.

Module Index
Update Packages 
Building complete list of updates ..

Now updating libraspberrypi-bin ..
Installing package(s) with command apt-get -y install libraspberrypi-bin ..
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libraspberrypi-bin : Depends: libraspberrypi0 (= 1.20130617-1) but 1.20130524-1 is to be installed
E: Unable to correct problems, you have held broken packages.
.. install failed!

Now updating libraspberrypi-dev ..
Installing package(s) with command apt-get -y install libraspberrypi-dev ..
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libraspberrypi-dev : Depends: libraspberrypi0 (= 1.20130617-1) but 1.20130524-1 is to be installed
E: Unable to correct problems, you have held broken packages.
.. install failed!

Now updating libraspberrypi-doc ..
Installing package(s) with command apt-get -y install libraspberrypi-doc ..
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libraspberrypi-doc : Depends: libraspberrypi0 (= 1.20130617-1) but 1.20130524-1 is to be installed
E: Unable to correct problems, you have held broken packages.
.. install failed!

Now updating libraspberrypi0 ..
Installing package(s) with command apt-get -y install libraspberrypi0 ..
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libraspberrypi0 : Depends: raspberrypi-bootloader (= 1.20130617-1) but 1.20130524-1 is to be installed
E: Unable to correct problems, you have held broken packages.
.. install failed!
  • 2
    Welcome to the community. Please include in your post what you have already tried, what hasn't worked, etc. so we can better help. – Butters Aug 16 '13 at 13:14
  • 1
    Thank you Butters. I tried everything I could find and nothing worked. Finally I tried sudo apt-get install --reinstall raspberrypi-bootloader. That took care of everything. I hope this can help someone else. – Mark Aug 17 '13 at 6:48
  • @mark that seems to be the actual answer. – jitter Sep 3 '17 at 21:50
4

Finally I tried

sudo apt-get install --reinstall raspberrypi-bootloader 

That took care of everything. I hope this can help someone else.

  • 1
    Guess what happens when I try that... More libraspberrypi0 dependency issues!!! – JSideris Apr 20 '15 at 6:40
1

I had the exact problem happen to me. In my case, the Pi crashed mid-upgrade. Mark's solution did not work when I tried it, however I used the suggested command:

sudo apt-get -f install

and it solved the unmet dependencies and handled the re-installation of the incompletely upgraded packages.

If dpkg returns with one package still being in a "very inconsistant state" then follow up with a forced reinstallation by using:

sudo apt-get install --reinstall <*package_name*>
0

I tried everything and nothing work... UNTILL I GOT MAD AND TRIED THIS: sudo rm /var/cache/apt/archives/raspberrypi-bootloader_1.20170703-1_armhf.deb

In case that package doesn't exist then just go to that directory (archives) and type "sudo rm raspber" (without quotation marks of course) and use the tab command to find the package in the directory that you want (which is raspberrypi-boot..etc).

Once package is removed then type "cd" and then issue this command: sudo apt-get install -f

It will take around 15 minutes and a lot of output but it fixed the problem!!! I didn't have the broken dependency anymore!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.