-1

I am currently trying to connect my Raspberry Pi 3 to Wifi, but the UI is telling me "No wireless interface found".

Here is my ifconfig :

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.23.218  netmask 255.255.0.0  broadcast 169.254.255.255
        ether b8:27:eb:07:ea:13  txqueuelen 1000  (Ethernet)
        RX packets 12234  bytes 782479 (764.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 11712  bytes 7580720 (7.2 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 13  bytes 642 (642.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13  bytes 642 (642.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.115  netmask 255.255.255.0  broadcast 192.168.0.255
        ether b8:27:eb:52:bf:46  txqueuelen 1000  (Ethernet)
        RX packets 251  bytes 64870 (63.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 27  bytes 3782 (3.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 00:c0:ca:95:a4:71  txqueuelen 1000  (Ethernet)
        RX packets 326  bytes 98072 (95.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 412 (412.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

As you can see, I have two wireless interfaces. The default one on the Raspberry, and another one that I usually use for my computer, but I decided to give it a try.

Here is my /etc/network/interfaces

auto lo
iface lo inet loopback
# The primary network interface
auto eth0
#iface lo inet interface
iface eth0 inet static
address 169.254.23.218
netmask 255.255.0.0
gateway 169.254.168.188
dns-nameservers 8.8.8.8 8.8.4.4

auto wlan0
iface wlan0 inet dhcp

source-directory /etc/network/interfaces.d

My static ip adress on eth0 is so that I can connect in SSH directly via ethernet from my laptop, because I have no screen for my RaspberryPi.

I also tried

sudo ifconfig wlan0 down
sudo ifconfig wlan0 up

and

sudo dhcpcd wlan0

but that does not solve the problem.

Do you have any idea that could help me ?

Thanks a lot, Djaz

0

There are a number of issues with your /etc/network/interfaces

  1. You have ignored the warning "# Please note that this file is written to be used with dhcpcd # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'"
  2. You are attempting to assign a Link-local address to eth0 and even more pointlessly to the gateway.
  3. You are not invoking /etc/wpa_supplicant/wpa_supplicant.conf (so it is a mystery how wlan0 got an address).
  4. There is no wlan1 section
  5. You are calling dhcp which will prevent dhcpcd running resulting in "No wireless interface found".

See How to set up networking/WiFi for correct settings, although you would be better using the current Raspbian, rather than the obsolete, unsupported Jessie.

PS It is unclear what, if anything, the 2nd wireless interface is suposed to do.

| improve this answer | |
0

If you manually setup a wireless connection in /etc/wpa_supplicant/wpa_supplicant.conf, make sure there are no spaces around the equal sign after the network keyword. Also make sure of other formatting like not adding commas after each line

network={

}

And not

network = {

}

All these make access to wpa_supplicant.conf inaccessible by the OS.

You can also run the following to find the exact problem:

sudo killall wpa_supplicant
sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0

Find more on this post: WiFi won't start

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.