0

I want to use Bluetooth of Raspberry Pi3 and also I want to Connect GSM module sim800l to Raspberry Pi3 ,in this instruction Bluetooth will be disable , what is the the best way to use both of them?

From this link I add enable_uart=1 in /boot/config.txt and I did this:

sudo apt-get install ppp
sudo wget "https://www.modmypi.com/download/sakis3g.tar.gz" -O sakis3g.tar.gz
sudo tar -xzvf sakis3g.tar.gz
sudo chmod +x sakis3g
sudo nano /etc/sakis3g.conf

in sakis3g.conf I added this :

CUSTOM_TTY="/dev/ttyS0"
BAUD=9600
APN=CUSTOM_APN
CUSTOM_APN=”sim apn”

I run sudo ./sakis3g ----interactive connect the ouput is

Modem unable to register a network.

connection failed

The sim doesn't have password So why the module cannot connect to internet?

0

The tutorial you linked uses rpi-update

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."

sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

There is NO reason to disable Bluetooth.

To use serial use dev/serial0 see How do I make serial work on the Raspberry Pi3 , Pi3B+, PiZeroW

  • I did what you said, enable serial port and disable serial console, but after restart pi3 both of them is enable why? and I edit CUSTOM_TTY="/dev/ttyS0" to CUSTOM_TTY="/dev/serial0" in sakis3.conf. when I run sudo ./sakis3g ----interactive connect sometimes output is Modem unable to register a network. and sometimes in step connecting ,show connected fail why it not connect to network? – isan Nov 3 '18 at 15:27
  • This was due to the power supply, if the module is fed properly, it can be connected to the Internet, it should feed 4.2 volts with 2A – isan Nov 10 '18 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.