0

I am trying to share a folder from Windows 10, and mount on my Raspberry Pi 3. These are the steps I followed.

  1. Changed the permissions of a folder in windows, to give it full access to everyone.
  2. Created a new user in that Windows system with username=BB, password=123.
  3. Updated and upgraded Pi, and then installed samba, samba-common-bin, cifs-utils.
  4. Connected Pi to Windows using ethernet cable, through a static IP.
  5. Wrote the following line in fstab.
  6. //169.254.168.190/Documents /home/pi/testbuy cifs username=BB,password=123,uid=1002,iocharset=utf8,dir_mode=0777,file_mode=0777,vers=2.0 0 0

  7. Executed the command sudo mount -a


But I am getting permission denied error, tried all the versions, and tried to change add sec parameters. None of them worked.

1

Try:

  1. Change to vers=3.0 to use the newest version of the protocol.
  2. Manually mount with sudo mount -t cifs -o username=BB,... //169.254... /home/pi/testbuy
  3. Use smbclient //169.254... to test it with an interactive client
  4. dmesg | tail -n10 to see if there are any kernel messages with hints

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.