0

I had a long time I didn't get my hand on the RPi. I got the Emlid image burned on a 8gb micro sdcard using the dd command. I have the pi connected to a the screen using HDMI to VGI cable, but I get no display. I changed the RPi (2B and 3B), the SD card, the OS (Emlid and wheezy) and also the HDMI to VGI cable, I even tried the cable to display the screen of my laptop and worked but I don't understand why it doesn't work with the RPi.Any help will be appreciated, Thank you.

  • I'd suggest getting it working with the latest 'Raspbian Stretch with Desktop' and if possible a TV/Monitor that has hdmi input. – CoderMike Nov 7 '18 at 14:28
  • I don't think I can afford a monitor that has hdmi input. but i tried to output my laptop screen and it worked – B.rayane Nov 7 '18 at 14:53
  • You don't already have a TV with hdmi? At least try 'Raspbian Stretch with Desktop' raspberrypi.org/downloads/raspbian with your hdmi to vga cable, wheezy is out of date. Use Etcher balena.io/etcher to flash to the sd card. – CoderMike Nov 7 '18 at 14:59
  • I did what you asked me to do but still not working. can you suggest for me some more tests to see where is the probleme – B.rayane Nov 8 '18 at 8:04
2

In the config.txt file you will probably need to set hdmi_force_hotplug. It's possible that the Pi doesn't recognise that it is plugged into a hdmi device due to the hdmi/vga conversion. By default it only activates the hdmi output if it recognises an hdmi connection.

The config.txt file is in the /boot partition (this is the fat32 partition) so you can edit it from Windows on the sdcard. You'll probably find the lines:

#hdmi_force_hotplug=1
#hdmi_drive=2

in the config.txt file. (if you don't then create them). Uncomment (remove the '#' from the beginning of the line) the line for hdmi_force_hotplug. So it looks like:

hdmi_force_hotplug=1

This will tell the Pi to activate the hdmi output even if nothing is connected (bypassing the detection routine).

If that still hasn't worked are you absolutely sure that your PSU is sufficient? An insufficient power supply can also be responsible for lack of hdmi output.

  • Some docs about all that: raspberrypi.org/documentation/configuration/config-txt/video.md – goldilocks Nov 7 '18 at 17:34
  • Thanks for the answer, I uncommented that line but still not working. for the power supply I tried with both the charger and the cable plugged to my PC. My Pi flashing so I don't think there is a wrong with it. Is there anyway to do it with ethernet cable using ubuntu!!!. – B.rayane Nov 8 '18 at 10:06
  • Try adding the setting 'hdmi_safe=1' to the config.txt See the documentation on video options for the RPi here raspberrypi.org/documentation/configuration/config-txt/video.md – Charemer Nov 8 '18 at 12:19
  • I bought a new RPi, I reburned the image in the SD card using Etcher but still can't display on the monitor, I was thinking that it might be the image burned so how can I check if I burn it correctly – B.rayane Nov 20 '18 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.