1

So we got a Powered USB Hub thinking we could use the Pi for a media share, but the HDD refuses to be detected. I saw this question asked countless times on Google and Stack Exchange, but they are all old threads or the people were just making rookie mistakes, we've been at this for a while now and we can't figure out the issue.

We checked the voltage and Amps (coming in the RPi power supply) with a USB meter and we have: 5.01V 0.825A

We tried with USB Flash drives = all good
We tried the HDD directly on the Pi = no good
We tried the HDD directly in the hub without power = no good
We tried the HDD directly in the hub with power = no good
We tried the hard drive in a laptop = all good, working
We tried several HDD sizes 1TB-4TB = no good
We tried FAT32 and HFS = no good
We tried unplugging everything except the screen = no good

Here's the output of dmesg after plugging the HDD:

[   58.311593] Voltage normalised (0x00000000)
[   60.391578] Under-voltage detected! (0x00050005)
[   64.551542] Voltage normalised (0x00000000)
[   71.756436] w1_master_driver w1_bus_master1: Attaching one wire slave 00.800000000000 crc 8c
[   71.763651] w1_master_driver w1_bus_master1: Family 0 for 00.800000000000.8c is not registered.
[   77.031561] Under-voltage detected! (0x00050005)
[   81.191562] Voltage normalised (0x00000000)
[   98.071507] usb 1-1.2: new high-speed USB device number 6 using dwc_otg
[   98.201860] usb 1-1.2: New USB device found, idVendor=1a40, idProduct=0101
[   98.201875] usb 1-1.2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[   98.201884] usb 1-1.2: Product: USB 2.0 Hub
[   98.202600] hub 1-1.2:1.0: USB hub found
[   98.202690] hub 1-1.2:1.0: 4 ports detected
[  100.071580] usb 1-1.2.3: new high-speed USB device number 7 using dwc_otg
[  100.213176] usb 1-1.2.3: New USB device found, idVendor=0bc2, idProduct=ab2a
[  100.213195] usb 1-1.2.3: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[  100.213204] usb 1-1.2.3: Product: BUP Fast HDD
[  100.213212] usb 1-1.2.3: Manufacturer: Seagate
[  100.213220] usb 1-1.2.3: SerialNumber: NA7F2Y8T
[  100.214038] usb-storage 1-1.2.3:1.0: USB Mass Storage device detected
[  100.214403] scsi host0: usb-storage 1-1.2.3:1.0
[  101.272550] scsi 0:0:0:0: Direct-Access     Seagate  BUP Fast HDD     9408 PQ: 0 ANSI: 6
[  101.274890] sd 0:0:0:0: [sda] Spinning up disk...
[  101.295262] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  101.991590] Under-voltage detected! (0x00050005)
[  102.311504] .
[  103.351513] .
[  104.391503] .
[  105.431514] .
[  106.471504] .
[  107.511496] .
[  108.551504] .
[  109.591499] .
[  110.631486] .
[  111.671505] .
[  112.711512] .
[  113.751497] .
[  114.791498] .
[  115.831499] .
[  116.871481] .
[  117.911516] .
[  118.631544] Voltage normalised (0x00000000)
[  118.951495] .

The screen we are using is the official RPi 7" HDMI screen and we unfortunately need to leave it plugged in the RPi to have display, even plugging the screen in an external USB power source still shows a blank screen. I'm wondering if the screen is drawing too much power but then again, we have a powered USB hub so it shouldn't be a problem.

UPDATE AND SOLUTION: Ater checking the current a hard drive gets from a computer or from the wall output (0.7A-1A) and comparing it with the powered USB hub on the RPi (0.3A-0.4A), we figured out the hub was probably crappy (even if we paid 20$) and might have a resistance in there to prevent too much power from getting in. So we built our own "redneck engineering" USB hub in the picture below, which is basically just the regular HDD black USB cable soldered to GND and VCC of the transparent dual USB cable from an old HDD (One would probably be enough). Then we plug the transparent cable in an external USB source.

The only downside of that issue is that even when the RPi is unplugged from its powersource, all the USB devices (like the screen) are still getting power from that transparent cable. hand-made USB power

  • First of all check if you have under voltage errors without the HDD attached (also try with all USB devices removed). If there are still errors then you need to solve that problem first. And another possible problem is that the powered hub cannot keep the HDD powered up (especially when the drive is spinning up – Dirk Nov 8 '18 at 10:08
1

"We checked the voltage and Amps(sic) with a USB meter and we have: 5.01V 0.825A" - presumably this is of the USB HDD which would mean the average current drawn is 825mA i.e. the peak current would be much higher.

The Pi (at least the Pi3) can supply 1.2A (total) from USB. This is not managed on an individual port basis. Theoretically this should work with most USB2 drives, although my experience indicates this is unreliable. I suspect the transient performance is inadequate, but I have not actually measured this - I use a powered hub which does work.

If you are using a USB3 drive this may require more than the 600mA supported by USB2 - up to 900mA, but even with a hub the Pi would be incapable of performing the negotiation because it only has USB2 support. (Most hubs are not actually compliant with the standards anyway.)

The bottom line is you can not use a USB3 drive with the Pi. Choose one which is USB2 compliant and use a quality powered hub.

The dmesg log indicates your power supply is inadequate - most PSU (including the "official" supplies) fail to meet their specifications (at least those I have tested). I use a proper external PSU with decent sized cables, not one of the flimsy power packs.

  • The "5.01V 0.825A" was measured from the RPi's power supply, not make sure it was getting what it needed, not what was getting in the HDD, but you gave us the nudge into the right direction to analyze what the HDD needed! and make it work, thanks! – NaturalBornCamper Nov 9 '18 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.