1

I'm having some problems related to MagicMirror and OpenCV ("No module named builtins"). I think it is because I haven't been able to install futures in the correct version of Python.

When I run pip install futures in the terminal I get a message saying Requirement already satisfied and that the futures package is in Python 3.5.

Does anyone know how I can install futures to Python 2.7? Is there a command I can use in the terminal?

1

pip2 is the package manager for Python 2 and installs packages in the Python 2 site-package directory. Run pip2 -V to check which version it operates on - likely that will be 2.7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.