0

I've configured and can successfully connect via OpenVPN on my Asus router.

When I'm away from home, I'd like to be able to continue using pihole for dns - heres what i've tried

# pihole runs on 192.168.1.150
# added this to openvpn server.conf
push "dhcp-option DNS 192.168.1.150"

Here is also a sample from my client.ovpn, which i added when the server conf DNS config failed

...etc
auth SHA1
ns-cert-type server
dhcp-option DNS 192.168.1.150
...etc

Here is log output from my IOS openvpn client

enter image description here

In my case it looks like I've successfully added my pihole DNS to the VPN connection, but the client fails to block ad requests.

I'm testing this using https://blockads.fivefilters.org/?pihole

If I disconnect VPN and switch back to wifi, the pihole test works as expected for DNS 192.168.1.150, so i've triple checked its the correct IP

0

I got it working!!! Turns out I had not correctly setup the DNS in my WAN settings (but I had for LAN) - I guess the WAN settings needed to be updated because my PI is on the wireless network?

enter image description here

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.