I am currently working on a project using the Raspberry Pi 2 Model B board. All was working fine until today when I was connecting my Pi to my laptop and the IP host for my Pi was displayed as a dead host. I am using Advanced IP Scanner. This didn't happen until now. I went through many forums searching for a solution to this problem and I found quite a few people had the same issue but there was no proper solution available to solve my issue.

I have tried many things like reinstalling the OS, changing networks, changing LAN cables, and changing my laptop network settings. All these attempts have failed. All the other stuff on the Pi is working fine, including the USB ports etc. Also, the LAN port acknowledges a connection between the Pi and Laptop but it doesn't receive an IP, barring it from internet access.

  • what is the output of ifconfig? are you connecting to the pi directly from the laptop? if so, you'll need to configure static IP address on both laptop ethernet and raspberry pi Commented Nov 25, 2018 at 10:44

3 Answers 3


The problem may not be with your RPi at all, but with your network setup or configuration. In general a "Dead IP" is one that is still in your DNS cache (on your laptop, or in the configuration of your gateway/router), but the IP address is no longer valid.

You've given us no information about how your network is set up or configured. It would be helpful to know some basic information; i.e. do you have a router/gateway, are you using DHCP or static IPs, etc.?? Without more details, the "answers" you get will be mostly questions.

My best suggestion is that you learn some fundamentals on networking for example, or this, or this. Understanding the basic process for networking on your (small?) LAN, and the associated terminology will be of benefit to you.

  • I have provided my laptop internet through a WiFi connection and connected the laptop to the Pi using a LAN cable directly. I am using DHCP to assign IP addresses. what I have been doing is doing the connections as i mentioned above, then getting the IPv4 address my laptop has for the LAN cable connection ( then scanning for other devices connected by scanning in the range ( Usually i would get Pi at ".4" address and then using this address i would remotely access its terminal using Tera Term. I would also get Internet connectivity using the same procedure.
    – P_K
    Commented Nov 26, 2018 at 7:10

same bad experience, the problem is either in advanced IP scanner or in the user operating it ( not knowing all the tricks ), this lead me to use IP scanners on my phone, quiet reliable.

regarding direct Ethernet connection with the laptop, check if the cable os cross-over or not (cross-over is for peer to peer connection, the other one ( forgot its name), is for connection using switch or router)

  • Please don't talk about cross-over cable. It is an issue from the last century and not relevant for a RasPi or most other devices because they are able to detect it.
    – Ingo
    Commented Jun 12, 2019 at 11:55
  • no this is not the problem i am addressing, it is just a side remark Commented Jun 12, 2019 at 11:57
  • I mean, for users not so familiar with networking, it confuses more than that it help.
    – Ingo
    Commented Jun 12, 2019 at 11:59
  • yup you are right, Commented Jun 12, 2019 at 12:25

The simplest solution I found to this was restarting the router :) Same issues, did a restart, power cycled the pi, worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.