2

I've a Raspberry Pi Model B. I want to connect its serial output to my PC and view the logs generated by it.

My serial to USB converter board uses FTDI FT232RL and supports both 3.3V and 5V (using a jumper on the board) and I use the 3.3V setting (as indicated by tutorials).

My problem is that I can't see any output on screen and none of the board's LEDs would blink (If I'd seen garbage output, at least I'd begin to change some settings like baud rate, but it's blank).

Here's what I do:

  • Connect board to my computer
  • Connect the Rx pin of RPi to the Tx of board, and Tx to Rx (I've also tested connecting Tx to Tx and Rx to Rx)
  • Connect the ground pin of two devices together and power-on the RPi (The SD card contains Arch Linux)

A sample page to show me Rx and Tx on RPi : http://elinux.org/RPi_Low-level_peripherals
Connection settings:

baud rate=115200 , stop bit=1, data bit=8 and parity and flow control set to None

On Windows I use Putty and on Mac I use 'screen' command or ZTerm app. On Mac I've tried to connect to both '/dev/cu.xxxxx and /dev/tty.xxxxx, where xxxxx is my board's name.

I thought maybe my board is not working; I connected it to my laptop (both Mac and Windows), connected its Rx and Tx pins together and typed on keyboard. Everything that I typed, was shown on screen (and Rx and Tx LEDs also blinked for each keystroke).

I've also tested the Arch Linux on SD and it's working without a problem.

Could you please advise me on how to troubleshoot this problem? Thanks in advance


I think I spotted my first problem: I installed Raspbian and now at least I can see some text, but it contains some garbage.

A screenshot:

enter image description here

Any ideas on how to fix this? (I'm using the same config)

  • What software are you using on the RPi to generate the Serial output? You may want to check out this question on RaspberryPi.org to help test. – Butters Aug 21 '13 at 15:25
  • As you see in my answer in below, I'm able to see the logs now, but with some garbage characters. I even couldn't see logs related to booting up kernel – Mehdi Sarmadi Aug 22 '13 at 8:27
  • If you're seeing garbage, you may have the serial config incorrect, probably the rate. Try some others. – Peter Loron Dec 21 '13 at 0:36
  • If you get something semi-legible like that, it means the UART is close to working. Baud rate is correct. Perhaps your wires are too long/picking up noise or the stop bits are incorrect etc. – John La Rooy Sep 3 '14 at 7:04
1

Firstly, don't use the 5V setting, you could damage the RPi pins

To see the console messages, you need something like

console=ttyAMA0,115200 kgdboc=ttyAMA0,115200

in your /boot/cmdline.txt

Here is the setup that worked for me.

Note that if you're not powering the RPi from the PC, you must connect the grounds together

  • I'm using 3.3V settings. The grounds are connected together and here's my "cmdline.txt"'s relevant section: ""console=ttyAMA0,115200 kgdboc=ttyAMA0,115200"" – Mehdi Sarmadi Aug 22 '13 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.