1

Even though the contents of /boot/cmdline.txt seem right...

$ cat /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=a435ca9f-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait cgroup_enable=cpuset cgroup_enable=memory cgroup_memory=1

I get:

$ cat /proc/cgroups
#subsys_name    hierarchy       num_cgroups     enabled
cpu     6       49      1
cpuacct 6       49      1
blkio   7       49      1
memory  5       78      1
devices 2       49      1
freezer 3       1       1
net_cls 4       1       1

How can I enable the cpuset cgroup?

I am trying Raspian Lite (Stretch) and Hypriot (1.9.0) I am open to other distros or whatever to get this working.

Hope this is supported on the Pi Zero W, ARMv6 hardware...

0

It block me for a long time too, and finially, I found that cpuset was enabled in raspbian jessie. you can try this one: http://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2017-07-05/

and then add cgroup_enable=cpuset cgroup_enable=memory cgroup_memory=1 to boot/cmdline.txt

you can get more kernel info from here: https://github.com/raspberrypi/linux/blob/rpi-4.9.y/arch/arm/configs/bcmrpi_defconfig I have no idea why they disable it by default in newer kernel.

here is my pi zero, I enabled CONFIG_CGROUP_PIDS=y on kernel additionally:

$ uname -a
Linux edge-zero01 4.9.80+ #3 Sat Aug 15 16:20:14 CST 2020 armv6l GNU/Linux
$ cat /proc/cgroups 
#subsys_name    hierarchy   num_cgroups enabled
cpuset  2   7   1
cpu 3   7   1
cpuacct 3   7   1
blkio   4   7   1
memory  5   29  1
devices 6   54  1
freezer 7   7   1
net_cls 8   7   1
pids    9   7   1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.