0

I've got an HDMI touchscreen for my Raspberry Pi, and the instructions say to add the following to the end of the config.txt file:

max_usb_current=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0

The documentation at https://www.raspberrypi.org/documentation/configuration/config-txt/video.md says that hdmi_cvt takes =:

hdmi_cvt=<width> <height> <framerate> <aspect> <margins> <interlace> <rb>

I've found examples of both on the Internet and on this site.

Which is correct?

  • By the way you should only have one 'hdmi_mode' entry. – CoderMike Nov 27 '18 at 17:14
  • @Dirk, because I can't get the screen working (it works fine plugged into a laptop, and it works fine with hdmi_safe=1), and I'm trying to work out whether the instructions are wrong, or if I'm doing something else wrong. – Roger Lipscombe Nov 27 '18 at 17:29
  • Add a link to the screen. – CoderMike Nov 27 '18 at 18:16
  • because I can't get the screen working well, logic tells me that it only takes 2 boots. If both don't work then the rest of the line has an error and it's irrelevant if you need the equal sign or not. – Dirk Nov 27 '18 at 18:34
  • So you have an answer below: both work. Time to solve the real problem :) – Dirk Nov 27 '18 at 18:35
2

I've just tested this on my Pi3 with 5 inch touchscreen - both work - with and without the '='.

hdmi_group=2
hdmi_mode=87
hdmi_cvt=800 480 60 6 0 0 0

Worked

hdmi_group=2
hdmi_mode=87
hdmi_cvt 800 480 60 6 0 0 0

Worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.