I updated my Pi yesterday.
Afterwards my own sh program, which is for switching audio-outputs stopped starting with the error message Failed to execute child process "xterm".
The programm uses the #!/bin/bash start command.
Its still possible to run it when calling it directly from the command line, but executing by clicking on it isn't.
So I installed xterm, but when starting the script it opens in a weird window with strange font, font-size and so on.
What's the matter?

  • Did you reboot after the upgrade?
    – Seamus
    Commented Dec 1, 2018 at 18:29
  • Yep. I did that.
    – itzFlubby
    Commented Dec 2, 2018 at 10:03

4 Answers 4


What I did was placing a sympbolic link which retains the execution code reference:

sudo ln -s /usr/bin/lxterminal /usr/bin/xterm

I had the same issue until I ran this command into the terminal: sudo apt-get install xterm for some reason after the update xterm went missing by itself. Before you run it you might want to delete xterm first if it's already installed by running sudo apt-get delete xterm

  • 1
    The apt-get program does not have a command delete. Do you mean command remove or purge, maybe with option --autoremove? You should update your answer.
    – Ingo
    Commented Apr 9, 2019 at 10:24

1) Open Terminal

Click on the Terminal Window.

2) cd /usr/bin

sets target directory (actually changes directory.) for cp (copy) command.

3) sudo cp lxterminal xterm

It makes another copy of "lxterminal" and re-names it to "xterm" (old terminal) so you can use both lxterminal and xterm command to start terminal.

Problem Solved Enjoy.

  • 2
    Welcome ExTremTR! Please edit your answer to show what those commands do and why your answer fixes the OP question?
    – Vincent P
    Commented Jan 11, 2020 at 18:39

After days of being unable to solve this problem, I tried the super trivial approach, to just copy the file lxterminal from /usr/bin/ and rename it to xterm and BOOM, problem solved.

  • Then no soup for you! And by soup I mean xterm updates. Commented Apr 9, 2019 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.