I'm new to Raspberry pi and electronics in general. All worked fine (a node webserver, reading a DHT22 sensor) then I tried this tutorial - https://www.raspberrypi.org/magpi/breadboard-tutorial/. It didn't work, and now neither does my pi. No console, no ethernet, no wifi; I can't get in.

I imagine I've done something wrong when following the tutorial - can it be that I wired everything up with my pi switched off, then switched it on? Can the LED have been the wrong way round?

Is it possible to diagnose/recover the pi?

enter image description here close up of LED

  • I'm fairly new also. What os or operating system are you using on the sd card? All I'm running is Kali. Is it possible you have corrupted your sd? – Ron Swartz Dec 1 at 15:40
  • What do the board LEDs do when you plug it and try to boot? – goldilocks Dec 1 at 15:49
  • Just the red power LED lights up – minisaurus Dec 1 at 15:49
  • May we have a close-up of the LED/resistor area? At the moment it's impossible to say how the LED is being powered. Perhaps you have simply shorted the 3V3 supply to ground through the LED. – joan Dec 1 at 17:10
  • I've added a close-up of the LED/resistor area. – minisaurus Dec 2 at 10:12

Just the red power LED lights up

That could, as Ron S. points out in the first comment, mean just a corrupted card.

On an undamaged pi (most models, at least), if the green led doesn't light at all, either there is no card inserted, or else it is completely rejecting it (== corrupt boot sector). If you attach a monitor and get the big rainbow square, that would be good news as it is consistent with this this possibility. Conversely, if you don't, it is likely a bad sign.

I don't see anything in your photo that is wrong. I can't tell whether the LED is the wrong way round but that is not dangerous.

can it be that I wired everything up with my pi switched off, then switched it on

In this case no, but in general, until/unless you understand the circuit you are experimenting with and the default boot state of the pins you are using, detach anything you are uncertain about when cycling the power.

  • 1
    No, no rainbow when a monitor is attached. But I'll try and make a new SD card and try that, and update here. – minisaurus Dec 2 at 10:13
  • I inserted the SD card into my PC's reader and got this output from tail -f /var/log/syslog "Dec 2 12:44:15 paul-HP-15-Notebook-PC kernel: [ 222.368235] mmc0: cannot verify signal voltage switch Dec 2 12:44:15 paul-HP-15-Notebook-PC kernel: [ 222.783237] mmc0: error -110 whilst initialising SD card" – minisaurus Dec 2 at 12:09
  • Actually I'm not sure if the rainbow screen happens as part of the bootloader (which is on the card) -- I'll check later unless I forget. If the card reader or controller are damage though, that's it. – goldilocks Dec 2 at 15:13
  • Doh! The fact that you found that log on the SD card, though, is indicative of the fact that subsequent to the error it was accessed and written to. – goldilocks Dec 2 at 16:15
  • No, the log is from my linux PC upon which I tried to mount the pi SD card ... the output from various SD readers on my Linux PC suggests that the card is fried, so hopefully the pi isn't. I think I should go and buy a new official pi SD card and give it a try – minisaurus Dec 2 at 16:53

The image, as shown, will do nothing - because there are no connections.

You appear to have a LED between 3.3V and Gnd - SO when powered it should glow - if not try reversing it (nothing will be damaged). You could try connecting to 5V to test if the LED is OK.

If it still doesn't glow you have probably blown the 3.3V regulator. This would be due to a short or some other cause (like using a bare board on a conducting surface). In this case the Pi is likely dead! A multimeter would enable you to confirm if there is no 3.3V on the pin.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.