I am using a SixFab IoT shield to send sms via my Pi and I am stuck with a stupid issue.

I am using one of their sample examples.

The code goes like this:

  sendSMS.py - This is basic SMS Service example.
  Created by Yasin Kaya (selengalp), October 31, 2018.
from cellulariot import cellulariot
import time

node = cellulariot.CellularIoT()


node.sendSMS("xxxxxxxxxxxxx","hello world!")

My terminal is not able to parse the AT command x1A and stuck at that point. MY board has network I did check it with the commands given. Anybody who had worked with this please help.

  • 1
    what does this mean? not able to parse the AT command x1A ..... if it an error, then what is the exact error message that you are getting? – jsotola Dec 2 '18 at 0:41
  • it keeps on printing x1A on terminal – Pankaj Jain Dec 17 '18 at 17:51

I solved the issue by sing this command node.setMode(GSM_ANY), what this does is, it gives the module independence to hop to different bands so that we are not stuck on the same one. The basic UDP example sets a fixed band of 900 which does not works in my case and causes the module to loose its network. Used lycamobile simcard

  • can you show the code of the working example? – Maux Oct 11 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.