I'm following raspberrypi.org THE RASPBERRY PI UARTS guide, trying to connect from mac 10.13.6 High Sierra to Pi 3 using screen.

I had to disable system integrity protection on mac (high sierra) to get the cp1202 kext loaded. Once i did that, i was able to see the /dev/cu.SLAB_USBtoUART. I tried connecting using screen, but saw only garbage characters. I have disabled hciuart service, disabled serial login shell (kinda odd, but that's what the guide suggests), still only seeing garbage.

To clarify, I'm trying to establish a serial connection from mac to PI, so i can get to PI's shell via screen (for example) from mac.

Any help is much appreciated!

cp2102 drivers I'm using

end of /boot/config.txt

# Additional overlays and parameters are documented 
/boot/overlays/README
# Disabling Bluetooth overlay
dtoverlay=pi3-disable-bt
dtoverlay=pi3-miniuart-bt

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# NOOBS Auto-generated Settings:^M
hdmi_force_hotplug=1^M
enable_uart=1
gpu_mem=128

/boot/cmdline.txt

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

/lib/systemd/system/hciuart.service

[Unit]
Description=Configure Bluetooth Modems connected by UART
ConditionPathIsDirectory=/proc/device-tree/soc/gpio@7e200000/bt_pins
Before=bluetooth.service
After=dev-serial1.device

[Service]
Type=forking
ExecStart=/usr/bin/btuart

[Install]
WantedBy=multi-user.target

I have used a similar device (but not for some time). On the Mac this appears as /dev/tty.SLAB_USBtoUART. (AFAIK there is no need to disable SIP - the driver should be included).

I am not sure why you fiddled with the Bluetooth on the Pi but if you don't do this dev/serial0 should work (provided UART is enabled). See How do I make serial work on the Raspberry Pi3 , Pi3B+, PiZeroW

It is also unclear exactly what you expect hciuart.service to do (or if you have modified it) or indeed exactly what you are trying to do with the serial interface.

EDIT

If you want a Console use raspi-config to enable "login shell". You DO NOT need to fiddle with Bluetooth settings (the mini UART is more than capable of acting as a console).

I just tried on latest Raspbian - this gives login prompt, but there are a number of errors. I used the following.

screen /dev/tty.SLAB_USBtoUART 9600,cs8,-echo,-parenb,-echo

Unfortunately I do not know the cause, this used to work with older versions of Raspbian. I suspect a clocking error with the new governor.

EDIT2 I decided to do some further investigation. Using Serial Tools on the Mac (this is a free download from the Apps Store - and much friendlier than the arcane Screen) and minicom on the Pi serial communication seems to operate normally.

Any problems seem to only impact on the Serial Console.

  • Based on the instructions in the guide i referenced pi3-disable-bt disables the Bluetooth device and restores UART0/ttyAMA0 to GPIOs 14 and 15, and t is also necessary to disable the system service that initialises the modem so it doesn't use the UART: sudo systemctl disable hciuart. pi3-miniuart-bt switches the Raspberry Pi 3 and Raspberry Pi Zero W Bluetooth function to use the mini UART (ttyS0), and restores UART0/ttyAMA0 to GPIOs 14 and 15. Similar things are written in the link you posted. Still, connecting from mac to pi does not give me shell, and when i reboot i see garbage. – Alex Dec 2 at 4:43
  • @Alex I don't see how anyone could follow that "guide" - I have used serial on both the Mac and Pi (and lots of other devices over the last 50 years) but I don't understand all the waffle in it. What are you ACTUALLY trying to achieve? NOTE DO NOT post detail in Comments - edit into your question. – Milliways Dec 2 at 4:44
  • after fighting with this thing some more, I was finally able to get to login prompt. The last thing i did that might've helped was i updated packages, and the distro. – Alex Dec 2 at 6:54
  • @Millways Thank you for your help! Cheers! – Alex Dec 2 at 6:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.