1

I have an RPi3 B+ on which I had set up NextCloudPi, using an external USB drive to store files to. Everything worked fine, so I decided to put the RPi into a case. I used an original RPi case. When I switched everything on again, the RPi did not boot. Only the red PWR LED lit up. I've taken the SD card (a 32GB Sandisc Extreme) out and put it in my Mac, which gives a warning that it can not mount the card. Any attempt to format the card fails with both disc utility and SD Card Formatter. Disc utility, SD Formatter and Etcher all only see a 32 MB (!) drive, but fail to format or burn to it. Also, the card gets really hot, even when it is in the Mac.

This morning I bought a new card, this time a Sandisc Ultra 16 GB. I downloaded the latest NextCloudPi image and burnt it using Etcher. The card mounted fine and I added an empty text file to its root partition called SSH in order to enable ssh access. I put it into the RPi with only the (original) powersupply and an HDMI cable to the monitor connected. Again, only the red PWR light lit up. No activity on the ACT light. The RPi does not boot, the monitor says there's no HDMI signal. Now, when I insert this SD card in the Mac, it again can not be read by the Mac, and I can not format the drive or burn a new image to it. All three programmes again only see a 32 MB drive that can fails to format or burn.

There is nothing visibly wrong with any of the SD cards.

Any suggestions what could be the cause of this or how to troubleshoot this going further would be very welcome.

  • What power supply are you using? – CoderMike Dec 2 '18 at 14:02
  • @CoderMike RS Components model DSA-13PFC-05 – Rene Beekman Dec 3 '18 at 19:20
1

If you see ONLY a 32Mb drive the SD Card is faulty. This has happened to me once, and a few others. I contacted Sandisk concerning this.

You should return the card to be replaced under warranty. You are truly unfortunate to have this happen twice. It is a rare fault.

  • Any thoughts on why the SD card heats up as the OP indicated? – Seamus Dec 3 '18 at 18:23
  • @Milliways my concern is that both cards at first worked and only stopped working after I put them in the RPi. Is there any way the RPi could be responsible for this? Which would mean I would simply fry any new card that I would put into this device... – Rene Beekman Dec 3 '18 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.