0

I have a raspberry pi 2 running raspbian, and bought a wifi dongle to use with it. I can't seem to get it connect to the internet. I have tried following the guide given by the seller, but it was written for Headed units, and I want to go headless. I also tried using sudo raspi-config to set up the internet.

output of ifconfig

output of lsusb

Version: Linux raspberry 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

  • and i can seem to get it to work My first reaction: so what's the problem? But it's probably a typo... Can you tell us what you tried already and what exactly doesn't seem to work? Also add the the version of your OS and the output of lsusb and ifconfig toyour question? – Dirk Dec 3 '18 at 19:21
  • 1
    I updated the question. – DinnerSpy Dec 3 '18 at 19:33
  • 1
    Please don't use pastebin, instead insert the output direct to the question. You are connected with two interfaces to your local network, one with wired ethernet, one with wifi. Where does the interface tun0 come from? Do you have a VPN client running? Which of these three interfaces is used to connect to the internet? Please address me with @Ingo, otherwise I won't see your reply. – Ingo Dec 3 '18 at 20:07
  • What's security does your network use? Can you see the SSID with an iwlist scan command? What's in your /etc/wpa_supplicant/wpa_supplicant.conf file? Have you set the country code in there? – Dougie Dec 3 '18 at 21:40
  • so you changed it from "I can seem to get it to work" - which implies it works - to "I can seem to get it to connect to the internet" - which also implies that it's working ... the opposite of can is can't - do you mean you can't make it work despite that fact that the wifi dongle is clearly working with a valid IP address ? – Jaromanda X Dec 3 '18 at 22:23
0

First thing that seems to be wrong is what Wifi dongle you are using. I suggest purchasing the following: https://www.ebay.com.au/itm/Edimax-EW-7811Un-WiFi-N150-USB-Adapter-for-Linux-MacOS-Windows-Raspberry-Pi/172798424298?hash=item283b96b4ea:g:KowAAOSwjS9ZfDpM:rk:1:pf:0 If your dongle is not driverless, you can't use it. Also, after connecting first try to use the GUI to connect to the internet. The GUI wifi button is in the top right hand corner. If that doesn't work, get your Wifi config app onto your desktop to use it. That allows for you to easily connect to the internet. If all that doesn't work, I point you to the following post: How do I set up networking/WiFi/static IP address?

This goes in detail in how to connect to the internet. If you could also update what are the results for the inputs sudo nano /etc/dhcpcd.conf and lsusb and ifconfig that would make the question clearer.

  • Thank you. I had that and a few issues other issues but this helped. My dongle dose not need drivers btw. – DinnerSpy Dec 4 '18 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.