1

Anyone else running docker AND Pi-Hole on Raspbian?

I wanted to experiment with docker on my RPi, but I've hit a brick wall. After installing the docker.io using apt, it can't seem to pull anything from the repositories. I keep getting either a 'Tag latest not found in repository' error or 'TLS handshake timeout' when specifying a different tag when pulling.

pi@raspberrypi:~ $ docker pull hello-world:latest
latest: Pulling from library/hello-world
6dd7e8e38242: Pulling fs layer
0e0e51368dbf: Pulling fs layer
Pulling repository docker.io/library/hello-world
Tag latest not found in repository docker.io/library/hello-world

pi@raspberrypi:~ $ docker pull nextcloud:rc-fpm
rc-fpm: Pulling from library/nextcloud
e1cf0272c6e7: Pulling fs layer
ec7769aeef26: Pulling fs layer
d46c3ea3cf53: Pulling fs layer
1e717012bed3: Pulling fs layer
d74110d2b082: Pulling fs layer
f48dc8a9b9cb: Pulling fs layer
3de3a8a262f9: Pulling fs layer
dd109f705e4b: Pulling fs layer
47e7adf112bf: Pulling fs layer
16d4e9901f22: Pulling fs layer
35dc90641aed: Pulling fs layer
97d19624f4bb: Pulling fs layer
88d4ea9e0bbc: Pulling fs layer
1d03df7088da: Pulling fs layer
8479cdcdfe35: Pulling fs layer
77bc14518cd9: Pulling fs layer
b0be80be7dd7: Pulling fs layer
89b743abe262: Pulling fs layer
330d615c1eae: Pulling fs layer
67d26b5e07a0: Pulling fs layer
92dd268cb14f: Pulling fs layer
4fe964875faa: Pulling fs layer
c102a2a36d09: Pulling fs layer
4d57f49c618a: Pulling fs layer
2ba54abdec49: Pulling fs layer
bb815eb77b78: Pulling fs layer
92461d12153e: Pulling fs layer
a94660707236: Pulling fs layer
612d1ee779c8: Pulling fs layer
2d5f90133cc0: Pulling fs layer
59c5927baf08: Pulling fs layer
147e5b4b18cf: Pulling fs layer
e6e7b8c91088: Pulling fs layer
81fb8350f2f4: Pulling fs layer
a2926bd6b76b: Pulling fs layer
Pulling repository docker.io/library/nextcloud
Error while pulling image: Get https://index.docker.io/v1/repositories                 /library/nextcloud/images: net/http: TLS handshake timeout

Could this be due to Pi-Hole which is running directly on the host OS? Maybe it's messing with the connection?

No solutions found online have helped me so far..

  • What version of the hardware and OS are you running and how did you install docker.io? – YetAnotherRandomUser Dec 6 '18 at 18:54
  • @YetAnotherRandomUser Hello, late answer but I am still having trouble with docker on my RPi. I am running Raspbian GNU/Linux 9.6 (stretch) on the RPi Model B. First I installed docker from the apt repositories, which resulted in the error documented here, but following that I tried many different versions and methods for installing docker which you can check out in my Reddit post over here. – dedavlade Dec 21 '18 at 0:01
2

I've had the same problem today while pulling resin/rpi-raspbian. Worked in Ubuntu VM, but not on the Pi. I've also used a Pyhton image a week ago. Now I could not pull it anymore. Docker was installed with apt.

(sudo apt install docker.io)

I just managed to solve it by removing docker and installing it via a script I found online.

Remove docker

sudo apt purge docker*

Install docker

curl -fsSL get.docker.com -o get-docker.sh && sh get-docker.sh

Source: https://medium.freecodecamp.org/the-easy-way-to-set-up-docker-on-a-raspberry-pi-7d24ced073ef

Hope this will help!

  • Welcome. That script (which you can read via get.docker.com) does not build anything from source. It identifies your distro and installs it with apt-get -- although it may not be doing it quite the same way as you did originally. You'd have to scrutinize it a bit for the details. – goldilocks Dec 11 '18 at 16:54
  • I must admit that I did not look at the script. Just Googled - Docker from source - and this command poped up. However, it solved my problem and it's just another way of installing Docker. – Ricardo van der Vlag Dec 11 '18 at 19:01
  • 3
    That script is well recommended. I added my comment in case someone else looking for a solution sees that and thinks, "Yikes! There must be a better way..." -- I don't know how long it would take to build from source on a Pi, but I suspect a while, and source builds are prone to various gotchas. Put another way, maybe you want to correct that above ;) – goldilocks Dec 11 '18 at 19:36
  • Thanks for your input. I have tried running the install script you provided, but that resulted in a SEGV Fault when starting the docker daemon, both stable and testing docker vers. And after some digging I found that the current version of docker might have a bug relating to my current architecture and OS, so I downgraded docker-ce to an earlier version (which got me a dependency error for docker-ce-cli) but now even though it runs all containers are immediately terminated on launch. – dedavlade Dec 21 '18 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.