EDIT 2: User Dougie already suggested this. Didn't notice it.

EDIT: I found a solution through NFS. On my Zyxel NAS326 I created a NFS share and gave right to access to it for my whole home network subnet (e.g. 192.168.1.0/24). Mounted the NFS share under /mnt/nfs/ and directed Transmission to download there. Works like charm.

For Plex server, which is running on my Pi 3, I used cifs to mount a share with movies. Cifs share was mounted under /mnt/samba/. I couldn’t be bothered to move all my movies to NFS share as take they up around 1TB.

This setup requires me to move files from share to share, but I have to do that either way, because PLEX separates movies from series and sometimes is very funky with the names.

My fstab looks like this:

nfs

192.168.1.180:/i-data/c12ab007/nfs/Downloads /mnt/nfs nfs user=jamesbond,atime,auto,rw,dev,exec,suid 0 0

cifs

//192.168.1.180/plex /mnt/samba cifs username=jamesbond,password=secretpassword 0 0


My goal is to get Transmission running on Pi 3 with VPN and it to use my ZyXel NAS326 as the storage. I’m having problems with permissions.

My main user that I’m using is called “focus” and it should have all permissions needed. I’ve managed to mount NAS share with no problems. I can create folders there from Pi and access the files already stored there. Here is proof: https://i.imgur.com/qw09WY0.png

My fstab line looks like this:

//192.168.1.180/plex/ /mnt/samba cifs username=focus,password=password123 0 0

My NAS also has identical user called “focus” with identical password. That user is an administrator on the NAS and has read/write permissions on “//192.168.1.180/plex/” share. https://i.imgur.com/GNit8Ap.png

I used this guide to install Transmission.

I did couple things differently. I did not set up incomplete directory as I don’t feel like I need it. I also pointed the download directory to my mounted NAS share. As seen here.

Whenever I try start a torrent download I get this error:

What I’ve tried (with no results, sadly):

-Adding “uid=1000” to end of fstab entry

-Adding “file_mode=0644,dir_mode=0755” to end of fstab entry

-Adding debian-transmission user to NAS and giving it permissions to “PLEX” folder, even though Transmissions is running under “focus” or atleast I think so. Found this after entering “ps -ef” https://i.imgur.com/vjRHNVI.png

-Changing share permissions through windows as I have the same share mounted on my PC, but I get permissions denied when I try changing the permissions.

  • My ZyXel NAS does NFS (network file system). That works really well with Linux and gets over all of the file permissions problems you're having. – Dougie Dec 6 at 1:59
  • 1
    Please don't use links, instead paste the results direct into the question. – Ingo Dec 6 at 19:17

ZyXel NAS systems (even my old NSA210 from ten years ago) support NFS (network file system). When the client system is Linux based, then it does not make sense to use CIFS/Samba if the NAS system can run NFS.

Activate NFS in the NAS control panel, export a shared filesystem and mount that on Linux.

The way I mount my NFS shares at boot time is with a systemd xxx.mount file. If the share is called /shared then the mount file is /etc/systemd/system/shared.mount.

[Unit]
Description=Mount shared directory
Requires=rpcbind.service network-online.target
Wants=network.service
#
# Replaces this line in fstab
#192.168.3.230:/i-data/cafebeef/nfs/shared /shared nfs defaults,noatime,x-systemd.automount 0 0
#
[Mount]
What=192.168.13.230:/i-data/cafebeef/nfs/shared
Where=/shared
Type=nfs
Options=defaults

[Install]
WantedBy=multi-user.target

Activate that with sudo systemctl enable shared.mount and mount it with sudo systemctl start shared.mount.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.