0

I have bought a raspberry pi zero w and performed the headless setup and used ssh to connect to my pc.But it does not detect the wifi interface and always gives 'No wireless interface found' when i use the bash command 'ifconfig -a'.I have tried many things like changing the wpa-supplicant file or network interface file but nothing works.Beside that my zero w is also correctly programmed as ' sudo cat /proc/device-tree/model' returns 'Raspberry Pi Zero W Rev 1.1'.The bluetooth is also not working.Can someone help me to solve this problem.Here is the output of 'lsmod' command.I thought it will be helpful the sort out the problem:

fuse 93037 3 spidev 7220 0 cfg80211 542402 0 rfkill 21476 2 cfg80211 snd_bcm2835 23253 1 snd_pcm 89686 1 snd_bcm2835 snd_timer 22428 1 snd_pcm snd 60154 5 snd_timer,snd_bcm2835,snd_pcm i2c_bcm2835 6465 0 spi_bcm2835 7456 0 w1_gpio 4566 0 wire 31600 1 w1_gpio cn 5687 1 wire hwmon 10505 1 wire fixed 3033 0 uio_pdrv_genirq 3718 0 uio 10006 1 uio_pdrv_genirq i2c_dev 6674 0 usb_f_ecm 7416 1 g_ether 5037 0 usb_f_rndis 17908 2 g_ether u_ether 12901 3 usb_f_ecm,g_ether,usb_f_rndis libcomposite 48212 3 usb_f_ecm,g_ether,usb_f_rndis dwc2 128996 0 udc_core 38862 5usb_f_ecm,dwc2,u_ether,usb_f_rndis,libcomposite ip_tables 12427 0 x_tables 22130 1 ip_tables ipv6 397455 22

  • What operating system you are using? Does sudo iw list give you detailed information about the wifi device? – Ingo Dec 8 '18 at 17:59
  • You "performed the headless setup" (whatever this may be) BUT how are you connected to the Pi - presumably by WiFi (or some other undisclosed method)? – Milliways Dec 8 '18 at 23:49
  • Have you set your wifi country. If not, then rfkill will disable all radio interfaces. Take a look with rfkill list all in a command line window [don't think it needs sudo]. – Dougie Dec 9 '18 at 18:10
0

I faced the same issue a month ago, searched everywhere but in the end, I just re-installed the operating system and everything worked without any issue.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.