2

So I have looked online and I even got different mics and adapters to get this working, but it still doesn't work. I was able to successfully setup my Alexa Pi on the RPi Zero W, because when I boot up the Pi there is an Alexa voice that says "Hello!" But when I say "Alexa" into the microphone it doesn't detect my voice commands. I know my microphone works and records fine because I tested it in Audacity on Windows 10.

I have edited asound.conf, alsa.conf asoundrc and alsa-base.conf are empty

asound.conf defaults.ctl.card 1 defaults.pcm.card 1 defaults.timer.card 1 pcm.!default { type hwcard 1 } ctl.!default { type hwcard 1 }

in alsa.conf I set defaults.pcm.card 1 and defaults.ctl.card 1

I have opened alsamixer and adjusted the mic volume to various levels. But it still doesn't work. I have also attached a picture of my setup.

Made in MS Paint

Please let me know if you need more info and thank you in advance for helping out! A little project for my robotics team.

  • so, using the exact same setup, including the USB sound card, works in windows 10? – Jaromanda X Dec 9 '18 at 0:44
  • @JaromandaX Yes, this will work to record audio and output via speaker with the usb sound card. But I am having problem with the raspberry pi. I know the sound card isn't the issue because the speaker works. Just not the microphone. – Kunal Singla Dec 9 '18 at 16:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.