0

I'm trying to get used to systemd, following this. But without success.

This file /etc/systemd/network/12-wlan1.network does not take effect:

[Match]
Name=wlan1
[Network]
Address=192.168.4.1/24
IPForward=yes
DHCPServer=yes
EOF

When I run ip a s the address is not assigned to wlan1.

I'm using a Raspberry Pi model B1 and two USB to wifi dongle.

The access point appears, but I can’t connect to it. How to find out what's going wrong there?

  • 3
    What OS are you running? If it's Raspbian then static addresses are done in /etc/dhcpcd.conf not with a systemd network file. – Dougie Dec 9 '18 at 17:54
  • 1
    Do you start with a fresh flashed Raspbian Stretch Lite? Do you mask networking.service and dhcpcd.service? What types are the USB/wifi dongles? Are they both the same? Have you tried to swap them? – Ingo Dec 9 '18 at 20:38
  • Yes. And yes. I'm using Edimax EW-7612UAn. Just used one dongle to try if it works. – jake Dec 9 '18 at 21:02
  • So, no guess how to troubleshoot this? Could it in general be an issue with the driver? Because on my notebook (running Ubuntu) I can give the dongle a new mac address.On my pi it doesn't work. – jake Dec 10 '18 at 21:03
  • 1
    You give me a pointer to this question on your other question Wifi Repeater – Set Interface down by Default (dhcpcd) belonging to the same task. Do you like to verify why wlan1 does not accept a static ip address, maybe on a spare SD Card? First suggestion is to test by setting it by hand with: sudo ip addr add 192.168.4.1/24 dev wlan1. – Ingo Feb 18 at 20:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.