0

I'm connected to university router, and I know they have many restrictions, but firefox is accessing the repo links without any issue, but the terminal can't.
How can I make the terminal use the same protocol as firefox?
Or, simply put, how can I update, install packages through apt?
Also, the ubuntu software package manager is throwing timeouts, I guess the internet is slow, but as I said, firefox is working just fine.

wadaane@wadaane-ubuntu:~$ sudo apt update
Err:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
403  Forbidden [IP: 91.189.91.26 80]
Err:2 http://sy.archive.ubuntu.com/ubuntu bionic InRelease
403  Forbidden [IP: 91.189.88.161 80]
Err:3 http://sy.archive.ubuntu.com/ubuntu bionic-updates InRelease
403  Forbidden [IP: 91.189.88.162 80]
Err:4 http://sy.archive.ubuntu.com/ubuntu bionic-backports InRelease
403  Forbidden [IP: 91.189.88.162 80]
Reading package lists... Done
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
E: The repository 'http://security.ubuntu.com/ubuntu bionic-security InRelease' is no longer signed.
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/bionic-security/InRelease  403  Forbidden [IP: 91.189.91.26 80]
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
E: The repository 'http://sy.archive.ubuntu.com/ubuntu bionic InRelease' is not signed.
E: Failed to fetch http://sy.archive.ubuntu.com/ubuntu/dists/bionic/InRelease  403  Forbidden [IP: 91.189.88.161 80]
E: Failed to fetch http://sy.archive.ubuntu.com/ubuntu/dists/bionic-updates/InRelease  403  Forbidden [IP: 91.189.88.162 80]
E: The repository 'http://sy.archive.ubuntu.com/ubuntu bionic-updates InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://sy.archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease  403  Forbidden [IP: 91.189.88.162 80]
E: The repository 'http://sy.archive.ubuntu.com/ubuntu bionic-backports InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
  • Are you saying that you can use Firefox to reach the IP addresses that are showing 403 Forbidden when using a terminal? – jsotola Dec 10 '18 at 18:34
  • Yes, Exactly :( – Wadaane Dec 10 '18 at 18:44
  • 1
    Do you have a proxy set in Firefox? Does Firefox get redirected to a login page before you can access resources outside of the network (ie. Internet)? – stevieb Dec 10 '18 at 19:28
  • no, no firefox proxy, no login. – Wadaane Dec 10 '18 at 19:33
  • This seems like a question that should be directed to your university's IT help. Otherwise there's always the really hard way around of creating a list of all the files you would need and then downloading them one by one. Also try wget directly and see what that does then try a terminal based browser like lynx. – T. M. Dec 11 '18 at 1:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.