3

I am trying to get composite video output from my raspberry pi to feed into my old CRT TV. I tried multiple times but without success. I bought an 4 pole 3.5mm RCA cable which was not according to the Raspberry Pi specification. So I modified it.

  • Ring 4=>Video
  • Ring 3=> Ground
  • Ring 2=> Right Audio
  • Tip=> Left Audio

I have tried installing Raspbian with and without Noobs; also ensured that the cable connection is correct(continuity check). Still got nothing.

I want to know if the Pi needs more power to output composite video. I'm using a normal smartphone charger that outputs 5V 1A.

  • Do you have hdmi connected as well? Is your TV NTSC or PAL? – CoderMike Dec 16 '18 at 16:41
  • No I don't have HDMI connected – Elish Dec 17 '18 at 4:14
1

Yes you probably need more power. The pi can do funny things when it doesn't have enough. The 3b+ needs a 2.5A charger in fact.

1

First, are you certain that you have modified the lead in the manner you think, are all the ground connections on the Video (Yellow?) and Audio-Left (White?) and Audio-Right (Red?) connected to the ground on the 4 pole 3.5mm connection?

BTW The connections are normally referred to from the tip as: Tip-Ring1-Ring2-Sleeve which is what I will use here.

Your pin-out does indicate the right connections though, which is a good start:

  • Tip - Right Audio
  • Ring 1 - Left Audio
  • Ring 2 - Ground
  • Sleeve - Video

You will also need to make sure you have the right Composite-Video-Blanking-Signal setting in your config.txt file, the values for sdtv_mode are:

  • 0 = Normal NTSC (3.57954545 MHz colour sub-carrier)
  • 1 = Japanese version of NTSC without a pedestal
  • 2 = Normal PAL (4.43361875 MHz colour sub-carrier)
  • 3 = Brazilian version of PAL (PAL-M) – 525 lines / 60 fields per second rather than 625 lines / 50 fields per second, (3.575611 MHz colour sub-carrier)

In the UK I need to use 2.

If you are connecting the TV via a Phono-to-SCART adapter or the TV has the RCA Phono inputs itself you do need to manually switch to the appropriate input manually, the TV will not switch to it automatically as it would with a full SCART interconnection like what you might have with a DVD or VCR.

You may also want to check that there is no setting that is forcing the RPi into using the HDMI connection - have a look through the relevant sections of the ELinux wiki documentation (from which I retrieved the above sdtv_mode details): RPiconfig.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.